aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql15-contrib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql15-contrib/Makefile')
-rw-r--r--databases/postgresql15-contrib/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/databases/postgresql15-contrib/Makefile b/databases/postgresql15-contrib/Makefile
new file mode 100644
index 000000000000..4db178d55483
--- /dev/null
+++ b/databases/postgresql15-contrib/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= postgresql
+PORTREVISION= 0
+CATEGORIES= databases
+
+MAINTAINER= pgsql@FreeBSD.org
+COMMENT= The contrib utilities from the PostgreSQL distribution
+
+MASTERDIR= ${.CURDIR}/../postgresql15-server
+
+USES= bison pgsql:${DISTVERSION:C/([0-9]\.?[0-9]).*/\1/g}
+
+BUILD_DIRS= src/port src/include src/common contrib
+INSTALL_DIRS= contrib
+
+# this port fails to build in parallel
+MAKE_JOBS_UNSAFE= yes
+
+SLAVE_ONLY= yes
+COMPONENT= -contrib
+CONFIGURE_ARGS= --disable-nls --with-uuid=bsd
+LDFLAGS+= -lpthread -L${PREFIX}/lib
+
+OPTIONS_DEFINE= DOCS OPENSSL XML
+OPTIONS_DEFAULT=OPENSSL XML
+OPTIONS_SUB= yes
+
+OPENSSL_DESC= Build with OpenSSL support
+OPENSSL_USES= ssl
+OPENSSL_CONFIGURE_WITH= openssl
+
+XML_CONFIGURE_WITH= libxslt libxml
+XML_LIB_DEPENDS=libxslt.so:textproc/libxslt \
+ libxml2.so:textproc/libxml2
+
+post-configure:
+ @cd ${WRKSRC}/src/backend && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} symlinks
+
+post-install:
+ @- ${INSTALL_DATA} ${WRKSRC}/contrib/README ${STAGEDIR}${DOCSDIR}/extension/README
+
+.include "${MASTERDIR}/Makefile"