aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql16-plpython
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql16-plpython')
-rw-r--r--databases/postgresql16-plpython/Makefile29
-rw-r--r--databases/postgresql16-plpython/pkg-descr4
2 files changed, 33 insertions, 0 deletions
diff --git a/databases/postgresql16-plpython/Makefile b/databases/postgresql16-plpython/Makefile
new file mode 100644
index 000000000000..55bb8de1ab4e
--- /dev/null
+++ b/databases/postgresql16-plpython/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= postgresql
+CATEGORIES= databases python
+# Keep the ?=, it is used as master by the other plpython ports.
+PORTREVISION?= 0
+PKGNAMESUFFIX?= ${WANT_PGSQL_VER:S/.//}${COMPONENT}
+
+MAINTAINER= pgsql@FreeBSD.org
+COMMENT= Module for using Python to write SQL functions
+WWW= https://www.postgresql.org/
+
+USES+= pgsql:${WANT_PGSQL_VER} ${WANT_PYTHON_USE}
+WANT_PGSQL= server
+
+MASTERDIR= ${.CURDIR}/../postgresql${WANT_PGSQL_VER:S/.//}-server
+
+WANT_PGSQL_VER?= 16
+WANT_PYTHON_USE?= python
+
+CONFIGURE_ARGS= --with-python
+COMPONENT= -plpython
+
+BUILD_DIRS= src/backend ${INSTALL_DIRS}
+INSTALL_DIRS?= src/pl/plpython contrib/hstore_plpython contrib/jsonb_plpython contrib/ltree_plpython
+SLAVE_ONLY= yes
+
+# this port fails to build in parallel
+MAKE_JOBS_UNSAFE= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql16-plpython/pkg-descr b/databases/postgresql16-plpython/pkg-descr
new file mode 100644
index 000000000000..61c4875985f7
--- /dev/null
+++ b/databases/postgresql16-plpython/pkg-descr
@@ -0,0 +1,4 @@
+PL/Python allows one to write PostgeSQL stored functions and
+procedures in Python (http://www.python.org/).
+
+This software is part of the standard PostgreSQL distribution.