aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql84-server/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql84-server/files')
-rw-r--r--databases/postgresql84-server/files/dot.cshrc.in13
-rw-r--r--databases/postgresql84-server/files/dot.profile.in18
-rw-r--r--databases/postgresql84-server/files/patch-aj118
-rw-r--r--databases/postgresql84-server/files/patch-contrib-retep-build37
-rw-r--r--databases/postgresql84-server/files/patch-doc-makefile19
-rw-r--r--databases/postgresql84-server/files/patch-jdbc-Connection51
-rw-r--r--databases/postgresql84-server/files/patch-jdbc-build-xml10
-rw-r--r--databases/postgresql84-server/files/patch-jdbc-getdate34
-rw-r--r--databases/postgresql84-server/files/pgsql.sh.tmpl36
-rw-r--r--databases/postgresql84-server/files/pkgIndex.tcl.in4
-rw-r--r--databases/postgresql84-server/files/post-install-notes25
-rw-r--r--databases/postgresql84-server/files/pre-install-notes21
12 files changed, 0 insertions, 386 deletions
diff --git a/databases/postgresql84-server/files/dot.cshrc.in b/databases/postgresql84-server/files/dot.cshrc.in
deleted file mode 100644
index a326041bff7b..000000000000
--- a/databases/postgresql84-server/files/dot.cshrc.in
+++ /dev/null
@@ -1,13 +0,0 @@
-set path = ( %%PREFIX%%/%%PG_PREFIX%%bin $path )
-
-setenv PGLIB %%PREFIX%%/%%PG_PREFIX%%lib
-
-# note: PGDATA can be overridden by the -D startup option
-setenv PGDATA $HOME/data
-
-#You might want to set some locale stuff here
-#setenv PGDATESTYLE ISO
-#setenv LC_ALL sv_SE.ISO_8859-1
-
-# if you want to make regression tests use this TZ
-#setenv TZ PST8PDT
diff --git a/databases/postgresql84-server/files/dot.profile.in b/databases/postgresql84-server/files/dot.profile.in
deleted file mode 100644
index 4aca6aadd19a..000000000000
--- a/databases/postgresql84-server/files/dot.profile.in
+++ /dev/null
@@ -1,18 +0,0 @@
-# both new and old layout's paths, but new path first...
-PATH=%%PREFIX%%/%%PG_PREFIX%%bin:${PATH}
-
-PGLIB=%%PREFIX%%/%%PG_PREFIX%%lib
-
-# note: PGDATA can be overridden by the -D startup option
-PGDATA=${HOME}/data
-
-export PATH PGLIB PGDATA
-
-#You might want to set some locale stuff here
-#PGDATESTYLE=ISO
-#LC_ALL=sv_SE.ISO_8859-1
-#export PGDATESTYLE LC_ALL
-
-# if you want to make regression tests use this TZ
-#TZ=PST8PDT
-#export TZ
diff --git a/databases/postgresql84-server/files/patch-aj b/databases/postgresql84-server/files/patch-aj
deleted file mode 100644
index 94c0d6d79991..000000000000
--- a/databases/postgresql84-server/files/patch-aj
+++ /dev/null
@@ -1,118 +0,0 @@
---- src/bin/pg_passwd/pg_passwd.c.orig Sat Mar 24 01:54:55 2001
-+++ src/bin/pg_passwd/pg_passwd.c Wed Apr 18 04:54:14 2001
-@@ -7,6 +7,12 @@
- #include <errno.h>
- #include <time.h>
- #include <ctype.h>
-+
-+#if defined(__FreeBSD__)
-+#include <pwd.h> /* defines _PASSWORD_LEN, max # of characters in a password */
-+#include <sys/time.h> /* gettimeofday for password salt */
-+#endif
-+
- #define issaltchar(c) (isalnum((unsigned char) (c)) || (c) == '.' || (c) == '/')
-
- #ifdef HAVE_TERMIOS_H
-@@ -23,18 +29,31 @@
- * We assume that the output of crypt(3) is always 13 characters,
- * and that at most 8 characters can usefully be sent to it.
- *
-+ * For FreeBSD, take these values from /usr/include/pwd.h
- * Postgres usernames are assumed to be less than NAMEDATALEN chars long.
- */
-+#if defined(__FreeBSD__)
-+#define CLEAR_PASSWD_LEN _PASSWORD_LEN
-+#define CRYPTED_PASSWD_LEN _PASSWORD_LEN /* max length, not containing NULL */
-+#define SALT_LEN 10
-+#else
- #define CLEAR_PASSWD_LEN 8 /* not including null */
- #define CRYPTED_PASSWD_LEN 13 /* not including null */
-+#define SALT_LEN 3
-+#endif
-+
-+static unsigned char itoa64[] = /* 0 ... 63 => ascii - 64 */
-+ "./0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
-+
-
- const char *progname;
-
- static void usage(void);
-+static void to64(char *s, long v, int n);
- static void read_pwd_file(char *filename);
- static void write_pwd_file(char *filename, char *bkname);
- static void encrypt_pwd(char key[CLEAR_PASSWD_LEN + 1],
-- char salt[3],
-+ char salt[SALT_LEN],
- char passwd[CRYPTED_PASSWD_LEN + 1]);
- static void prompt_for_username(char *username);
- static void prompt_for_password(char *prompt, char *password);
-@@ -47,6 +66,15 @@
- printf("Report bugs to <pgsql-bugs@postgresql.org>.\n");
- }
-
-+static void
-+to64(char *s, long v, int n)
-+{
-+ while (--n >= 0) {
-+ *s++ = itoa64[v&0x3f];
-+ v >>= 6;
-+ }
-+}
-+
- typedef struct
- {
- char *uname;
-@@ -154,7 +182,7 @@
- if (q != NULL)
- *(q++) = '\0';
-
-- if (strlen(p) != CRYPTED_PASSWD_LEN && strcmp(p, "+") != 0)
-+ if (strlen(p) > CRYPTED_PASSWD_LEN && strcmp(p, "+") != 0)
- {
- fprintf(stderr, "%s:%d: warning: invalid password length\n",
- filename, npwds + 1);
-@@ -221,15 +249,25 @@
-
- static void
- encrypt_pwd(char key[CLEAR_PASSWD_LEN + 1],
-- char salt[3],
-+ char salt[SALT_LEN],
- char passwd[CRYPTED_PASSWD_LEN + 1])
- {
-+#if !defined(__FreeBSD__)
- int n;
--
-+#endif
- /* select a salt, if not already given */
- if (salt[0] == '\0')
- {
-+#if defined(__FreeBSD__)
-+ struct timeval tv;
-+ srandomdev();
-+ gettimeofday(&tv,0);
-+ to64(&salt[0], random(), 3);
-+ to64(&salt[3], tv.tv_usec, 3);
-+ to64(&salt[6], tv.tv_sec, 2);
-+ salt[8] = '\0';
- srand(time(NULL));
-+#else
- do
- {
- n = rand() % 256;
-@@ -241,6 +279,7 @@
- } while (!issaltchar(n));
- salt[1] = n;
- salt[2] = '\0';
-+#endif
- }
-
- /* get encrypted password */
-@@ -335,7 +374,7 @@
- char *filename;
- char bkname[MAXPGPATH];
- char username[NAMEDATALEN];
-- char salt[3];
-+ char salt[SALT_LEN];
- char key[CLEAR_PASSWD_LEN + 1],
- key2[CLEAR_PASSWD_LEN + 1];
- char e_passwd[CRYPTED_PASSWD_LEN + 1];
diff --git a/databases/postgresql84-server/files/patch-contrib-retep-build b/databases/postgresql84-server/files/patch-contrib-retep-build
deleted file mode 100644
index 80f40f1cc86d..000000000000
--- a/databases/postgresql84-server/files/patch-contrib-retep-build
+++ /dev/null
@@ -1,37 +0,0 @@
-===================================================================
-RCS file: /home/projects/pgsql/cvsroot/pgsql/contrib/retep/build.xml,v
-retrieving revision 1.4
-retrieving revision 1.5
-diff -u -r1.4 -r1.5
---- contrib/retep/build.xml 2001/03/11 11:06:59 1.4
-+++ contrib/retep/build.xml 2001/05/16 16:20:51 1.5
-@@ -2,7 +2,7 @@
-
- build file to build the donated retep tools packages
-
-- $Id: build.xml,v 1.4 2001/03/11 11:06:59 petere Exp $
-+ $Id: build.xml,v 1.5 2001/05/16 16:20:51 momjian Exp $
-
- -->
-
-@@ -22,6 +22,11 @@
- <available property="xml" classname="org.xml.sax.Parser" />
- </target>
-
-+ <target name="warning" depends="checks" unless="jdk1.2+">
-+ <echo message="WARNING -- contributed retep tools need jdk1.2 or later -- compilation NOT done." />
-+ </target>
-+
-+
- <!-- Prepares the build by creating a directory to place the class files -->
- <target name="prepare">
- <mkdir dir="${dest}" />
-@@ -35,7 +40,7 @@
- </target>
-
- <!-- Builds the XML Tools -->
-- <target name="compile" depends="checks,prepare">
-+ <target name="compile" depends="checks,prepare,warning" if="jdk1.2+">
- <javac srcdir="${src}" destdir="${dest}">
- <include name="${package}/**" />
- </javac>
diff --git a/databases/postgresql84-server/files/patch-doc-makefile b/databases/postgresql84-server/files/patch-doc-makefile
deleted file mode 100644
index fa27bed2af3f..000000000000
--- a/databases/postgresql84-server/files/patch-doc-makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- doc/Makefile~ Sun Jan 7 03:03:22 2001
-+++ doc/Makefile Wed Apr 18 08:12:30 2001
-@@ -43,10 +43,13 @@
- gzip -d -c man.tar.gz | ( cd $(DESTDIR)$(mandir) && $(TAR) xf - )
- endif
-
--
- installdirs:
-- $(mkinstalldirs) $(DESTDIR)$(mandir) $(DESTDIR)$(docdir)/html
--
-+ifdef found_html
-+ $(mkinstalldirs) $(DESTDIR)$(docdir)/html
-+endif
-+ifdef found_man
-+ $(mkinstalldirs) $(DESTDIR)$(mandir)
-+endif
-
- uninstall:
- ifdef found_html
diff --git a/databases/postgresql84-server/files/patch-jdbc-Connection b/databases/postgresql84-server/files/patch-jdbc-Connection
deleted file mode 100644
index 26fbc260d639..000000000000
--- a/databases/postgresql84-server/files/patch-jdbc-Connection
+++ /dev/null
@@ -1,51 +0,0 @@
-===================================================================
-RCS file: /home/projects/pgsql/cvsroot/pgsql/src/interfaces/jdbc/org/postgresql/Connection.java,v
-retrieving revision 1.14
-retrieving revision 1.16
-diff -u -r1.14 -r1.16
---- src/interfaces/jdbc/org/postgresql/Connection.java 2001/01/31 08:26:01 1.14
-+++ src/interfaces/jdbc/org/postgresql/Connection.java 2001/06/01 20:57:58 1.16
-@@ -10,7 +10,7 @@
- import org.postgresql.util.*;
-
- /**
-- * $Id: Connection.java,v 1.14 2001/01/31 08:26:01 peter Exp $
-+ * $Id: Connection.java,v 1.16 2001/06/01 20:57:58 momjian Exp $
- *
- * This abstract class is used by org.postgresql.Driver to open either the JDBC1 or
- * JDBC2 versions of the Connection class.
-@@ -267,7 +267,8 @@
- //
- firstWarning = null;
-
-- java.sql.ResultSet initrset = ExecSQL("set datestyle to 'ISO'; select getdatabaseencoding()");
-+ java.sql.ResultSet initrset = ExecSQL("set datestyle to 'ISO'; " +
-+ "select case when pg_encoding_to_char(1) = 'SQL_ASCII' then 'UNKNOWN' else getdatabaseencoding() end");
-
- String dbEncoding = null;
- //retrieve DB properties
-@@ -307,9 +308,23 @@
- } else if (dbEncoding.equals("EUC_TW")) {
- dbEncoding = "EUC_TW";
- } else if (dbEncoding.equals("KOI8")) {
-- dbEncoding = "KOI8_R";
-+ // try first if KOI8_U is present, it's a superset of KOI8_R
-+ try {
-+ dbEncoding = "KOI8_U";
-+ "test".getBytes(dbEncoding);
-+ }
-+ catch(UnsupportedEncodingException uee) {
-+ // well, KOI8_U is still not in standard JDK, falling back to KOI8_R :(
-+ dbEncoding = "KOI8_R";
-+ }
-+
- } else if (dbEncoding.equals("WIN")) {
- dbEncoding = "Cp1252";
-+ } else if (dbEncoding.equals("UNKNOWN")) {
-+ //This isn't a multibyte database so we don't have an encoding to use
-+ //We leave dbEncoding null which will cause the default encoding for the
-+ //JVM to be used
-+ dbEncoding = null;
- } else {
- dbEncoding = null;
- }
diff --git a/databases/postgresql84-server/files/patch-jdbc-build-xml b/databases/postgresql84-server/files/patch-jdbc-build-xml
deleted file mode 100644
index b1c703a9c978..000000000000
--- a/databases/postgresql84-server/files/patch-jdbc-build-xml
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/interfaces/jdbc/build.xml~ Fri Mar 16 22:50:43 2001
-+++ src/interfaces/jdbc/build.xml Wed Apr 18 08:57:57 2001
-@@ -120,6 +120,7 @@
- <javac srcdir="${src}" destdir="${dest}">
- <include name="example/**" />
- <exclude name="example/corba/**"/>
-+ <exclude name="example/blobtest.java" unless="jdk1.2+"/>
- </javac>
- </target>
-
diff --git a/databases/postgresql84-server/files/patch-jdbc-getdate b/databases/postgresql84-server/files/patch-jdbc-getdate
deleted file mode 100644
index 744407ae14b5..000000000000
--- a/databases/postgresql84-server/files/patch-jdbc-getdate
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/interfaces/jdbc/org/postgresql/jdbc2/ResultSet.java~ Fri Feb 23 19:12:23 2001
-+++ src/interfaces/jdbc/org/postgresql/jdbc2/ResultSet.java Wed May 9 04:31:11 2001
-@@ -423,8 +423,13 @@
- String s = getString(columnIndex);
- if(s==null)
- return null;
--
-- return java.sql.Date.valueOf(s);
-+ // length == 10: SQL Date
-+ // length > 10: SQL Timestamp, assumes PGDATESTYLE=ISO
-+ try {
-+ return java.sql.Date.valueOf((s.length() == 10) ? s : s.substring(0,10));
-+ } catch (NumberFormatException e) {
-+ throw new PSQLException("postgresql.res.baddate", s);
-+ }
- }
-
- /**
-@@ -441,8 +446,13 @@
-
- if(s==null)
- return null; // SQL NULL
--
-- return java.sql.Time.valueOf(s);
-+ // length == 8: SQL Time
-+ // length > 8: SQL Timestamp
-+ try {
-+ return java.sql.Time.valueOf((s.length() == 8) ? s : s.substring(11,19));
-+ } catch (NumberFormatException e) {
-+ throw new PSQLException("postgresql.res.badtime",s);
-+ }
- }
-
- /**
diff --git a/databases/postgresql84-server/files/pgsql.sh.tmpl b/databases/postgresql84-server/files/pgsql.sh.tmpl
deleted file mode 100644
index cd78771219ed..000000000000
--- a/databases/postgresql84-server/files/pgsql.sh.tmpl
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-#
-# For postmaster startup options, edit $PGDATA/postgresql.conf
-
-PGBIN=%%PREFIX%%/%%PG_PREFIX%%bin
-
-case $1 in
-start)
- [ -d %%PREFIX%%/%%PG_PREFIX%%lib ] && /sbin/ldconfig -m %%PREFIX%%/%%PG_PREFIX%%lib
- [ -x ${PGBIN}/pg_ctl ] && {
- su -l pgsql -c \
- '[ -d ${PGDATA} ] && exec %%PREFIX%%/%%PG_PREFIX%%bin/pg_ctl start -s -w -l ~pgsql/errlog'
- echo -n ' pgsql'
- }
- ;;
-
-stop)
- [ -x ${PGBIN}/pg_ctl ] && {
- su -l pgsql -c 'exec %%PREFIX%%/%%PG_PREFIX%%bin/pg_ctl stop -s -m fast'
- echo -n ' pgsql'
- }
- ;;
-
-status)
- [ -x ${PGBIN}/pg_ctl ] && {
- exec su -l pgsql -c 'exec %%PREFIX%%/%%PG_PREFIX%%bin/pg_ctl status'
- }
- ;;
-
-*)
- echo "usage: `basename $0` {start|stop|status}" >&2
- exit 64
- ;;
-esac
diff --git a/databases/postgresql84-server/files/pkgIndex.tcl.in b/databases/postgresql84-server/files/pkgIndex.tcl.in
deleted file mode 100644
index bd8329b15c69..000000000000
--- a/databases/postgresql84-server/files/pkgIndex.tcl.in
+++ /dev/null
@@ -1,4 +0,0 @@
-# Package-index file for Pgtcl-package. Enables you to load PostgreSQL
-# interface functions right into you TCL-interpreter as simply as
-# package require Pgtcl
-package ifneeded Pgtcl 1.3 "load %%PREFIX%%/lib/libpgtcl.so"
diff --git a/databases/postgresql84-server/files/post-install-notes b/databases/postgresql84-server/files/post-install-notes
deleted file mode 100644
index 9347fc51c247..000000000000
--- a/databases/postgresql84-server/files/post-install-notes
+++ /dev/null
@@ -1,25 +0,0 @@
-
-Now that PostgreSQL is installed, you should read the documentation and
-implementation guides. These can be found at:
-
- http://www.PostgreSQL.org/docs
-
-You may wish to subscribe to the PostgreSQL user-support mailing list.
-Send an e-mail to pgsql-questions-request@postgresql.org with the
-text "subscribe" in the message body.
-
-If you built PostgreSQL with TCL/TK support, you can use the pgaccess
-utility to get a TCL/TK based database frontend for database
-operations. You do NOT need to install the pgaccess port separately.
-
-If you built in the TCL support, you can load the Pg package into your
-TCL scripts as easily as ``package require Pgtcl''.
-
-If you built with Java support, add
-/usr/local/share/java/classes/postgresql.jar to your classpath.
-
-If you have many tables and many clients running, consider raising
-kern.maxfiles using sysctl(8).
-
-Use createlang(1) to install languages into your database.
-Supported languages are 'plpgsql', 'pltcl', 'pltclu', and 'plperl'.
diff --git a/databases/postgresql84-server/files/pre-install-notes b/databases/postgresql84-server/files/pre-install-notes
deleted file mode 100644
index 697ce3cedb79..000000000000
--- a/databases/postgresql84-server/files/pre-install-notes
+++ /dev/null
@@ -1,21 +0,0 @@
- * IMPORTANT UPGRADE NOTICE * IMPORTANT UPGRADE NOTICE *
-
-The PostgreSQL port now obeys hier(7) by default, which means that it
-installs into:
-
-%%PREFIX%%/bin
-%%PREFIX%%/lib
-%%PREFIX%%/include/pgsql
-
-You *must* move away your old installation to avoid problems with
-ldconfig(8) and user's PATH:s. If you rather install using the
-old-fashion layout, cancel at next screen and run make as:
-
-$ make -DWITH_OLD_LAYOUT
-
-As always, you *must* dump existing databases before stopping and
-removing your old postgresql, as part of the update. This is *NOT*
-done by this port!
-
-If you want JAVA support, I will try to determine your JAVA_HOME using
-javavmwrapper. If you want a different JVM, please set JAVA_HOME.