aboutsummaryrefslogtreecommitdiff
path: root/databases/py-fastparquet/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/py-fastparquet/files')
-rw-r--r--databases/py-fastparquet/files/patch-pyproject.toml6
-rw-r--r--databases/py-fastparquet/files/patch-setup.py20
2 files changed, 26 insertions, 0 deletions
diff --git a/databases/py-fastparquet/files/patch-pyproject.toml b/databases/py-fastparquet/files/patch-pyproject.toml
new file mode 100644
index 000000000000..d5a65bd2f937
--- /dev/null
+++ b/databases/py-fastparquet/files/patch-pyproject.toml
@@ -0,0 +1,6 @@
+--- pyproject.toml.orig 2023-04-20 20:00:36 UTC
++++ pyproject.toml
+@@ -1,2 +1,2 @@
+ [build-system]
+-requires = ["setuptools", "wheel", "Cython >= 0.29.23", "oldest-supported-numpy", "pytest-runner"]
++requires = ["setuptools", "wheel", "Cython >= 0.29.23", "numpy"]
diff --git a/databases/py-fastparquet/files/patch-setup.py b/databases/py-fastparquet/files/patch-setup.py
new file mode 100644
index 000000000000..aa3535977588
--- /dev/null
+++ b/databases/py-fastparquet/files/patch-setup.py
@@ -0,0 +1,20 @@
+--- setup.py.orig 2022-11-18 01:33:09 UTC
++++ setup.py
+@@ -44,7 +44,6 @@ else:
+ extra = {'ext_modules': cythonize(modules, language_level=3)}
+
+ install_requires = open('requirements.txt').read().strip().split('\n')
+-subprocess.call(["git", "status"], stdout=sys.stdout, stderr=sys.stderr)
+
+ setup(
+ name='fastparquet',
+@@ -57,8 +56,7 @@ setup(
+ 'setuptools>18.0',
+ 'setuptools-scm>1.5.4',
+ 'Cython',
+- 'pytest-runner',
+- 'oldest-supported-numpy'
++ 'numpy'
+ ],
+ description='Python support for Parquet file format',
+ author='Martin Durant',