aboutsummaryrefslogtreecommitdiff
path: root/databases/rubygem-activerecord613
diff options
context:
space:
mode:
Diffstat (limited to 'databases/rubygem-activerecord613')
-rw-r--r--databases/rubygem-activerecord613/Makefile25
-rw-r--r--databases/rubygem-activerecord613/distinfo3
-rw-r--r--databases/rubygem-activerecord613/pkg-descr14
3 files changed, 42 insertions, 0 deletions
diff --git a/databases/rubygem-activerecord613/Makefile b/databases/rubygem-activerecord613/Makefile
new file mode 100644
index 000000000000..fef2f3dc8544
--- /dev/null
+++ b/databases/rubygem-activerecord613/Makefile
@@ -0,0 +1,25 @@
+# Created by: Johannes Meixner <johannes@perceivon.net>
+
+PORTNAME= activerecord
+PORTVERSION= 6.1.3.2
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 613
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Object-relational mapping layer for Rails MVC Framework
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-activemodel613>=${PORTVERSION}:databases/rubygem-activemodel613 \
+ rubygem-activesupport613>=${PORTVERSION}:devel/rubygem-activesupport613
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^6\.1\.
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-activerecord613/distinfo b/databases/rubygem-activerecord613/distinfo
new file mode 100644
index 000000000000..0fa7a8f225f0
--- /dev/null
+++ b/databases/rubygem-activerecord613/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633413635
+SHA256 (rubygem/activerecord-6.1.3.2.gem) = c8400e75c1caa43aefcc6dd1d21c427030f4190ee606931ff8f97da12a46e539
+SIZE (rubygem/activerecord-6.1.3.2.gem) = 429056
diff --git a/databases/rubygem-activerecord613/pkg-descr b/databases/rubygem-activerecord613/pkg-descr
new file mode 100644
index 000000000000..29c7987b2296
--- /dev/null
+++ b/databases/rubygem-activerecord613/pkg-descr
@@ -0,0 +1,14 @@
+Active Record connects classes to relational database tables to establish an
+almost zero-configuration persistence layer for applications. The library
+provides a base class that, when subclassed, sets up a mapping between the new
+class and an existing table in the database. In the context of an application,
+these classes are commonly referred to as models. Models can also be connected
+to other models; this is done by defining associations.
+
+Active Record relies heavily on naming in that it uses class and association
+names to establish mappings between respective database tables and foreign key
+columns. Although these mappings can be defined explicitly, it's recommended to
+follow naming conventions, especially when getting started with the library.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/activerecord