aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlcipher
diff options
context:
space:
mode:
Diffstat (limited to 'databases/sqlcipher')
-rw-r--r--databases/sqlcipher/Makefile8
-rw-r--r--databases/sqlcipher/distinfo6
-rw-r--r--databases/sqlcipher/files/patch-sqlcipher-libressl-2.731
-rw-r--r--databases/sqlcipher/pkg-descr2
4 files changed, 8 insertions, 39 deletions
diff --git a/databases/sqlcipher/Makefile b/databases/sqlcipher/Makefile
index 28535bede5f5..9d7267da906b 100644
--- a/databases/sqlcipher/Makefile
+++ b/databases/sqlcipher/Makefile
@@ -1,15 +1,17 @@
PORTNAME= sqlcipher
DISTVERSIONPREFIX= v
-DISTVERSION= 3.4.2
+DISTVERSION= 4.5.6
CATEGORIES= databases
MAINTAINER= jharris@widomaker.com
COMMENT= Encrypted SQLite database
+WWW= https://www.zetetic.net/sqlcipher/
LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= libedit libtool pathfix ssl tcl:86,build
+USES= cpe libedit libtool pathfix ssl tcl:86,build
+CPE_VENDOR= zetetic
USE_LDCONFIG= yes
USE_GITHUB= yes
diff --git a/databases/sqlcipher/distinfo b/databases/sqlcipher/distinfo
index 4f1ace00d3f2..f68afc1ded0f 100644
--- a/databases/sqlcipher/distinfo
+++ b/databases/sqlcipher/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518208810
-SHA256 (sqlcipher-sqlcipher-v3.4.2_GH0.tar.gz) = 69897a5167f34e8a84c7069f1b283aba88cdfa8ec183165c4a5da2c816cfaadb
-SIZE (sqlcipher-sqlcipher-v3.4.2_GH0.tar.gz) = 14743960
+TIMESTAMP = 1707945924
+SHA256 (sqlcipher-sqlcipher-v4.5.6_GH0.tar.gz) = e4a527e38e67090c1d2dc41df28270d16c15f7ca5210a3e7ec4c4b8fda36e28f
+SIZE (sqlcipher-sqlcipher-v4.5.6_GH0.tar.gz) = 18937692
diff --git a/databases/sqlcipher/files/patch-sqlcipher-libressl-2.7 b/databases/sqlcipher/files/patch-sqlcipher-libressl-2.7
deleted file mode 100644
index bda45d959ea3..000000000000
--- a/databases/sqlcipher/files/patch-sqlcipher-libressl-2.7
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/src/crypto_openssl.c b/src/crypto_openssl.c
-index a45db3b..4344076 100644
---- src/crypto_openssl.c.orig
-+++ src/crypto_openssl.c
-@@ -47,7 +47,7 @@ static unsigned int openssl_external_init = 0;
- static unsigned int openssl_init_count = 0;
- static sqlite3_mutex* openssl_rand_mutex = NULL;
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- static HMAC_CTX *HMAC_CTX_new(void)
- {
- HMAC_CTX *ctx = OPENSSL_malloc(sizeof(*ctx));
-@@ -117,7 +117,7 @@ static int sqlcipher_openssl_activate(void *ctx) {
-
- if(openssl_init_count == 0 && openssl_external_init == 0) {
- /* if the library was not externally initialized, then should be now */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- OpenSSL_add_all_algorithms();
- #endif
- }
-@@ -154,7 +154,7 @@ static int sqlcipher_openssl_deactivate(void *ctx) {
- Note: this code will only be reached if OpensSSL_add_all_algorithms()
- is called by SQLCipher internally. This should prevent SQLCipher from
- "cleaning up" openssl when it was initialized externally by the program */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000)
- EVP_cleanup();
- #endif
- } else {
diff --git a/databases/sqlcipher/pkg-descr b/databases/sqlcipher/pkg-descr
index 668d4a7c8fc9..a122136794fb 100644
--- a/databases/sqlcipher/pkg-descr
+++ b/databases/sqlcipher/pkg-descr
@@ -1,3 +1 @@
Allows the creation of encrypted SQLite databases
-
-WWW: http://www.sqlcipher.net