aboutsummaryrefslogtreecommitdiff
path: root/databases/webdis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/webdis/Makefile')
-rw-r--r--databases/webdis/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/databases/webdis/Makefile b/databases/webdis/Makefile
new file mode 100644
index 000000000000..d792dd51a760
--- /dev/null
+++ b/databases/webdis/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= webdis
+DISTVERSION= 0.1.14
+CATEGORIES= databases
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= HTTP interface for Redis
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libevent.so:devel/libevent
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= nicolasff
+USE_RC_SUBR= webdis
+
+USERS= webdis
+GROUPS= webdis
+
+PLIST_FILES= bin/webdis \
+ "@sample etc/webdis.conf.sample"
+
+post-patch:
+ ${REINPLACE_CMD} -e "s@%%LOCALBASE%%@${LOCALBASE}@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL} ${WRKSRC}/webdis ${STAGEDIR}${PREFIX}/bin/webdis
+ ${INSTALL_DATA} ${FILESDIR}/webdis.conf ${STAGEDIR}${PREFIX}/etc/webdis.conf.sample
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/webdis
+
+.include <bsd.port.mk>