aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile12
-rw-r--r--databases/php74-dba/Makefile9
-rw-r--r--databases/php74-dba/files/patch-config.m450
-rw-r--r--databases/php74-mysqli/Makefile9
-rw-r--r--databases/php74-mysqli/files/patch-mysqli__api.c13
-rw-r--r--databases/php74-mysqli/files/patch-php_mysqli_structs.h20
-rw-r--r--databases/php74-odbc/Makefile9
-rw-r--r--databases/php74-odbc/files/patch-config.m4111
-rw-r--r--databases/php74-pdo/Makefile9
-rw-r--r--databases/php74-pdo_dblib/Makefile9
-rw-r--r--databases/php74-pdo_firebird/Makefile9
-rw-r--r--databases/php74-pdo_mysql/Makefile9
-rw-r--r--databases/php74-pdo_odbc/Makefile9
-rw-r--r--databases/php74-pdo_pgsql/Makefile9
-rw-r--r--databases/php74-pdo_sqlite/Makefile9
-rw-r--r--databases/php74-pgsql/Makefile9
-rw-r--r--databases/php74-sqlite3/Makefile9
17 files changed, 0 insertions, 314 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 6d86bdab2f43..733c7875b9c4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -597,18 +597,6 @@
SUBDIR += pguri
SUBDIR += php-tarantool
SUBDIR += php-xapian
- SUBDIR += php74-dba
- SUBDIR += php74-mysqli
- SUBDIR += php74-odbc
- SUBDIR += php74-pdo
- SUBDIR += php74-pdo_dblib
- SUBDIR += php74-pdo_firebird
- SUBDIR += php74-pdo_mysql
- SUBDIR += php74-pdo_odbc
- SUBDIR += php74-pdo_pgsql
- SUBDIR += php74-pdo_sqlite
- SUBDIR += php74-pgsql
- SUBDIR += php74-sqlite3
SUBDIR += php80-dba
SUBDIR += php80-mysqli
SUBDIR += php80-odbc
diff --git a/databases/php74-dba/Makefile b/databases/php74-dba/Makefile
deleted file mode 100644
index af5519aeea97..000000000000
--- a/databases/php74-dba/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -dba
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-dba/files/patch-config.m4 b/databases/php74-dba/files/patch-config.m4
deleted file mode 100644
index 30f662138374..000000000000
--- a/databases/php74-dba/files/patch-config.m4
+++ /dev/null
@@ -1,50 +0,0 @@
---- config.m4.orig 2016-01-06 15:14:47 UTC
-+++ config.m4
-@@ -324,6 +324,38 @@ if test "$PHP_DB4" != "no"; then
- THIS_PREFIX=$i
- THIS_INCLUDE=$i/include/db5.3/db.h
- break
-+ elif test -f "$i/include/db5/db.h"; then
-+ THIS_PREFIX=$i
-+ THIS_INCLUDE=$i/include/db5/db.h
-+ break
-+ elif test -f "$i/include/db48/db.h"; then
-+ THIS_PREFIX=$i
-+ THIS_INCLUDE=$i/include/db48/db.h
-+ break
-+ elif test -f "$i/include/db47/db.h"; then
-+ THIS_PREFIX=$i
-+ THIS_INCLUDE=$i/include/db47/db.h
-+ break
-+ elif test -f "$i/include/db46/db.h"; then
-+ THIS_PREFIX=$i
-+ THIS_INCLUDE=$i/include/db46/db.h
-+ break
-+ elif test -f "$i/include/db44/db.h"; then
-+ THIS_PREFIX=$i
-+ THIS_INCLUDE=$i/include/db44/db.h
-+ break
-+ elif test -f "$i/include/db43/db.h"; then
-+ THIS_PREFIX=$i
-+ THIS_INCLUDE=$i/include/db43/db.h
-+ break
-+ elif test -f "$i/include/db42/db.h"; then
-+ THIS_PREFIX=$i
-+ THIS_INCLUDE=$i/include/db42/db.h
-+ break
-+ elif test -f "$i/include/db41/db.h"; then
-+ THIS_PREFIX=$i
-+ THIS_INCLUDE=$i/include/db41/db.h
-+ break
- elif test -f "$i/include/db5.1/db.h"; then
- THIS_PREFIX=$i
- THIS_INCLUDE=$i/include/db5.1/db.h
-@@ -366,7 +398,7 @@ if test "$PHP_DB4" != "no"; then
- break
- fi
- done
-- PHP_DBA_DB_CHECK(4, db-5.3 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
-+ PHP_DBA_DB_CHECK(4, db-5 db-5.3 db-5.1 db-5.0 db-4.8 db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
- fi
- PHP_DBA_STD_RESULT(db4,Berkeley DB4)
-
diff --git a/databases/php74-mysqli/Makefile b/databases/php74-mysqli/Makefile
deleted file mode 100644
index 3d39ef5e7667..000000000000
--- a/databases/php74-mysqli/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -mysqli
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-mysqli/files/patch-mysqli__api.c b/databases/php74-mysqli/files/patch-mysqli__api.c
deleted file mode 100644
index 2d88e061f9da..000000000000
--- a/databases/php74-mysqli/files/patch-mysqli__api.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- mysqli_api.c.orig 2019-12-17 10:29:23 UTC
-+++ mysqli_api.c
-@@ -31,8 +31,9 @@
- #include "zend_smart_str.h"
- #include "php_mysqli_structs.h"
- #include "mysqli_priv.h"
-+#if defined(MYSQLI_USE_MYSQLND)
- #include "ext/mysqlnd/mysql_float_to_double.h"
--
-+#endif
-
- #if !defined(MYSQLI_USE_MYSQLND)
- /* {{{ mysqli_tx_cor_options_to_string */
diff --git a/databases/php74-mysqli/files/patch-php_mysqli_structs.h b/databases/php74-mysqli/files/patch-php_mysqli_structs.h
deleted file mode 100644
index 68568dd214fd..000000000000
--- a/databases/php74-mysqli/files/patch-php_mysqli_structs.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- php_mysqli_structs.h.orig 2010-07-26 15:52:54.000000000 +0200
-+++ php_mysqli_structs.h 2010-07-26 15:53:14.000000000 +0200
-@@ -36,7 +36,7 @@
- #define FALSE 0
- #endif
-
--#ifdef MYSQLI_USE_MYSQLND
-+#if defined(MYSQLI_USE_MYSQLND)
- #include "ext/mysqlnd/mysqlnd.h"
- #include "mysqli_mysqlnd.h"
- #else
-@@ -53,6 +53,8 @@
- #undef HAVE_MBSTATE_T
- #define WE_HAD_MBSTATE_T
- #endif
-+
-+typedef zend_ulong ulong;
-
- #if defined(ulong) && !defined(HAVE_ULONG)
- #define HAVE_ULONG
diff --git a/databases/php74-odbc/Makefile b/databases/php74-odbc/Makefile
deleted file mode 100644
index 309218574011..000000000000
--- a/databases/php74-odbc/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -odbc
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-odbc/files/patch-config.m4 b/databases/php74-odbc/files/patch-config.m4
deleted file mode 100644
index 04efc6ded7c9..000000000000
--- a/databases/php74-odbc/files/patch-config.m4
+++ /dev/null
@@ -1,111 +0,0 @@
---- config.m4.orig 2019-08-06 06:54:18 UTC
-+++ config.m4
-@@ -91,6 +91,9 @@ AC_DEFUN([PHP_ODBC_FIND_EMPRESS_BCS_LIBS
- dnl
- dnl configure options
- dnl
-+PHP_ARG_ENABLE(odbc,,
-+[ --enable-odbc Enable ODBC support with selected driver])
-+
-
- PHP_ARG_WITH([odbcver],,
- [AS_HELP_STRING([[--with-odbcver[=HEX]]],
-@@ -102,7 +105,7 @@ PHP_ARG_WITH([odbcver],,
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([adabas],,
- [AS_HELP_STRING([[--with-adabas[=DIR]]],
-- [Include Adabas D support [/usr/local]])])
-+ [Include Adabas D support [/usr/local]])], [no], [no])
-
- AC_MSG_CHECKING([for Adabas support])
- if test "$PHP_ADABAS" != "no"; then
-@@ -132,7 +135,7 @@ fi
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([sapdb],,
- [AS_HELP_STRING([[--with-sapdb[=DIR]]],
-- [Include SAP DB support [/usr/local]])])
-+ [Include SAP DB support [/usr/local]])], [no], [no])
-
- AC_MSG_CHECKING([for SAP DB support])
- if test "$PHP_SAPDB" != "no"; then
-@@ -153,7 +156,7 @@ fi
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([solid],,
- [AS_HELP_STRING([[--with-solid[=DIR]]],
-- [Include Solid support [/usr/local/solid]])])
-+ [Include Solid support [/usr/local/solid]])], [no], [no])
-
- AC_MSG_CHECKING(for Solid support)
- if test "$PHP_SOLID" != "no"; then
-@@ -181,7 +184,7 @@ fi
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([ibm-db2],,
- [AS_HELP_STRING([[--with-ibm-db2[=DIR]]],
-- [Include IBM DB2 support [/home/db2inst1/sqllib]])])
-+ [Include IBM DB2 support [/home/db2inst1/sqllib]])], [no], [no])
-
- AC_MSG_CHECKING(for IBM DB2 support)
- if test "$PHP_IBM_DB2" != "no"; then
-@@ -222,7 +225,7 @@ if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([empress],,
- [AS_HELP_STRING([[--with-empress[=DIR]]],
- [Include Empress support $EMPRESSPATH (Empress Version >= 8.60
-- required)])])
-+ required)])], [no], [no])
-
- AC_MSG_CHECKING(for Empress support)
- if test "$PHP_EMPRESS" != "no"; then
-@@ -248,7 +251,7 @@ if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([empress-bcs],,
- [AS_HELP_STRING([[--with-empress-bcs[=DIR]]],
- [Include Empress Local Access support $EMPRESSPATH (Empress Version >=
-- 8.60 required)])])
-+ 8.60 required)])], [no], [no])
-
- AC_MSG_CHECKING(for Empress local access support)
- if test "$PHP_EMPRESS_BCS" != "no"; then
-@@ -294,7 +297,7 @@ PHP_ARG_WITH([custom-odbc],,
- your include dirs. For example, you should define following for Sybase SQL
- Anywhere 5.5.00 on QNX, prior to running this configure script:
- CPPFLAGS="-DODBC_QNX -DSQLANY_BUG" LDFLAGS=-lunix
-- CUSTOM_ODBC_LIBS="-ldblib -lodbc"])])
-+ CUSTOM_ODBC_LIBS="-ldblib -lodbc"])], [no], [no])
-
- AC_MSG_CHECKING(for a custom ODBC support)
- if test "$PHP_CUSTOM_ODBC" != "no"; then
-@@ -317,7 +320,7 @@ fi
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([iodbc],,
- [AS_HELP_STRING([--with-iodbc],
-- [Include iODBC support])])
-+ [Include iODBC support])], [no], [no])
-
- AC_MSG_CHECKING(whether to build with iODBC support)
- if test "$PHP_IODBC" != "no"; then
-@@ -335,7 +338,7 @@ fi
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([esoob],,
- [AS_HELP_STRING([[--with-esoob[=DIR]]],
-- [Include Easysoft OOB support [/usr/local/easysoft/oob/client]])])
-+ [Include Easysoft OOB support [/usr/local/easysoft/oob/client]])], [no], [no])
-
- AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
- if test "$PHP_ESOOB" != "no"; then
-@@ -358,7 +361,7 @@ fi
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([unixODBC],,
- [AS_HELP_STRING([--with-unixODBC],
-- [Include unixODBC support])])
-+ [Include unixODBC support])], [no], [no])
-
- AC_MSG_CHECKING(whether to build with unixODBC support)
- if test "$PHP_UNIXODBC" != "no"; then
-@@ -386,7 +389,7 @@ fi
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH([dbmaker],,
- [AS_HELP_STRING([[--with-dbmaker[=DIR]]],
-- [Include DBMaker support])])
-+ [Include DBMaker support])], [no], [no])
-
- AC_MSG_CHECKING(for DBMaker support)
- if test "$PHP_DBMAKER" != "no"; then
diff --git a/databases/php74-pdo/Makefile b/databases/php74-pdo/Makefile
deleted file mode 100644
index da1ba1f12714..000000000000
--- a/databases/php74-pdo/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -pdo
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-pdo_dblib/Makefile b/databases/php74-pdo_dblib/Makefile
deleted file mode 100644
index f319c420097b..000000000000
--- a/databases/php74-pdo_dblib/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -pdo_dblib
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-pdo_firebird/Makefile b/databases/php74-pdo_firebird/Makefile
deleted file mode 100644
index 429a9336cf6e..000000000000
--- a/databases/php74-pdo_firebird/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -pdo_firebird
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-pdo_mysql/Makefile b/databases/php74-pdo_mysql/Makefile
deleted file mode 100644
index d78142f112d3..000000000000
--- a/databases/php74-pdo_mysql/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -pdo_mysql
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-pdo_odbc/Makefile b/databases/php74-pdo_odbc/Makefile
deleted file mode 100644
index 10736c1e7992..000000000000
--- a/databases/php74-pdo_odbc/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -pdo_odbc
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-pdo_pgsql/Makefile b/databases/php74-pdo_pgsql/Makefile
deleted file mode 100644
index 6232942c69de..000000000000
--- a/databases/php74-pdo_pgsql/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -pdo_pgsql
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-pdo_sqlite/Makefile b/databases/php74-pdo_sqlite/Makefile
deleted file mode 100644
index 923f35f0e15e..000000000000
--- a/databases/php74-pdo_sqlite/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -pdo_sqlite
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-pgsql/Makefile b/databases/php74-pgsql/Makefile
deleted file mode 100644
index 3e262a5c5f30..000000000000
--- a/databases/php74-pgsql/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -pgsql
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"
diff --git a/databases/php74-sqlite3/Makefile b/databases/php74-sqlite3/Makefile
deleted file mode 100644
index 6fcaf4533b6c..000000000000
--- a/databases/php74-sqlite3/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-CATEGORIES= databases
-
-MASTERDIR= ${.CURDIR}/../../lang/php74
-
-PKGNAMESUFFIX= -sqlite3
-
-TEST_TARGET= test
-
-.include "${MASTERDIR}/Makefile"