aboutsummaryrefslogtreecommitdiff
path: root/deskutils/belcard
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/belcard')
-rw-r--r--deskutils/belcard/Makefile22
-rw-r--r--deskutils/belcard/distinfo6
-rw-r--r--deskutils/belcard/pkg-descr2
-rw-r--r--deskutils/belcard/pkg-plist7
4 files changed, 20 insertions, 17 deletions
diff --git a/deskutils/belcard/Makefile b/deskutils/belcard/Makefile
index df2273a9dc0d..256c5ab5812a 100644
--- a/deskutils/belcard/Makefile
+++ b/deskutils/belcard/Makefile
@@ -1,22 +1,26 @@
PORTNAME= belcard
-PORTVERSION= 1.0.2
-PORTREVISION= 2
+DISTVERSION= 5.2.94
CATEGORIES= deskutils
-MASTER_SITES= https://www.linphone.org/releases/sources/belcard/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= vCard support library
+WWW= https://www.linphone.org/
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libbctoolbox.so:net/bctoolbox \
libbelr.so:textproc/belr
-USES= cmake compiler:c++11-lib
+USES= cmake compiler:c++17-lang
+USE_GITLAB= yes
+GL_SITE= https://gitlab.linphone.org/BC
+GL_ACCOUNT= public
USE_LDCONFIG= yes
-CMAKE_ARGS= -DENABLE_STATIC=NO -DENABLE_STRICT=NO -DENABLE_UNIT_TESTS=NO
-WRKSRC= ${WRKDIR}/${DISTNAME}-0
+CMAKE_ARGS= -DCMAKE_PREFIX_PATH=${LOCALBASE} \
+ -DENABLE_STATIC=NO \
+ -DENABLE_STRICT=NO \
+ -DENABLE_UNIT_TESTS=NO
.include <bsd.port.mk>
diff --git a/deskutils/belcard/distinfo b/deskutils/belcard/distinfo
index 78caaebf8ebf..ae86201f74db 100644
--- a/deskutils/belcard/distinfo
+++ b/deskutils/belcard/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539599261
-SHA256 (belcard-1.0.2.tar.gz) = 1350f63bd183e5d8b05afa7673726362a55e196e7bde600a58cb421d28cd3e46
-SIZE (belcard-1.0.2.tar.gz) = 197955
+TIMESTAMP = 1690557583
+SHA256 (belcard-5.2.94.tar.bz2) = 009c9f139461f9978a4ffbb334c2d300d98ffd8194758a95a5ecd44a255fea9f
+SIZE (belcard-5.2.94.tar.bz2) = 150701
diff --git a/deskutils/belcard/pkg-descr b/deskutils/belcard/pkg-descr
index 19d32d2fea21..a6be9d13c305 100644
--- a/deskutils/belcard/pkg-descr
+++ b/deskutils/belcard/pkg-descr
@@ -1,3 +1 @@
Belcard is a C++ library to manipulate vCard files.
-
-WWW: https://www.linphone.org/
diff --git a/deskutils/belcard/pkg-plist b/deskutils/belcard/pkg-plist
index d921abcbf802..e65e22cef676 100644
--- a/deskutils/belcard/pkg-plist
+++ b/deskutils/belcard/pkg-plist
@@ -20,6 +20,7 @@ include/belcard/belcard_utils.hpp
include/belcard/vcard_grammar.hpp
lib/libbelcard.so
lib/libbelcard.so.1
-share/Belcard/cmake/BelcardConfig.cmake
-share/Belcard/cmake/BelcardTargets-%%CMAKE_BUILD_TYPE%%.cmake
-share/Belcard/cmake/BelcardTargets.cmake
+%%DATADIR%%/cmake/belcardConfig.cmake
+%%DATADIR%%/cmake/belcardTargets-%%CMAKE_BUILD_TYPE%%.cmake
+%%DATADIR%%/cmake/belcardTargets.cmake
+share/belr/grammars/vcard_grammar