aboutsummaryrefslogtreecommitdiff
path: root/deskutils/flameshot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/flameshot/Makefile')
-rw-r--r--deskutils/flameshot/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/deskutils/flameshot/Makefile b/deskutils/flameshot/Makefile
index 626095b57ebf..11b034bc457a 100644
--- a/deskutils/flameshot/Makefile
+++ b/deskutils/flameshot/Makefile
@@ -1,29 +1,29 @@
-# Created by: Nicola Stanislao Vitale <nivit@FreeBSD.org>
-
PORTNAME= flameshot
-PORTVERSION= 0.10.0
+PORTVERSION= 12.1.0
DISTVERSIONPREFIX= v
-CATEGORIES= deskutils
+PORTREVISION= 1
+CATEGORIES= deskutils wayland
MAINTAINER= nivit@FreeBSD.org
COMMENT= Powerful yet simple to use screenshot software
+WWW= https://flameshot.org/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake compiler:c++11-lang gl qmake qt:5
-
-CMAKE_INSTALL_PREFIX= ${STAGEDIR}/${PREFIX}
-
-GH_ACCOUNT= flameshot-org
+USES= cmake compiler:c++11-lang desktop-file-utils gl qmake qt:5
USE_GITHUB= yes
+GH_ACCOUNT= flameshot-org
USE_GL= gl
-USE_QT= core dbus gui linguist network svg widgets \
- buildtools_build
+USE_QT= core dbus gui linguist network svg widgets buildtools:build
+
+CMAKE_INSTALL_PREFIX= ${STAGEDIR}/${PREFIX}
post-patch:
@${REINPLACE_CMD} -e 's,$${CMAKE_INSTALL_FULL_BINDIR},${LOCALBASE}/bin,1' \
- ${WRKSRC}/data/dbus/org.flameshot.Flameshot.service.in
+ -e 's,^\(Exec=\)@LAUNCHER_EXECUTABLE@,\1${LOCALBASE}/bin/${PORTNAME},1' \
+ ${WRKSRC}/data/dbus/org.flameshot.Flameshot.service.in \
+ ${WRKSRC}/data/desktopEntry/package/org.flameshot.Flameshot.desktop
.include <bsd.port.mk>