aboutsummaryrefslogtreecommitdiff
path: root/deskutils/freebsd-update-notify/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/freebsd-update-notify/Makefile')
-rw-r--r--deskutils/freebsd-update-notify/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/deskutils/freebsd-update-notify/Makefile b/deskutils/freebsd-update-notify/Makefile
index 6fb0aa63b00b..74e2e3096a35 100644
--- a/deskutils/freebsd-update-notify/Makefile
+++ b/deskutils/freebsd-update-notify/Makefile
@@ -1,6 +1,5 @@
PORTNAME= freebsd-update-notify
-DISTVERSION= 0.1.0-2
-DISTVERSIONSUFFIX= -g9a58564
+DISTVERSION= 0.1.1
CATEGORIES= deskutils
MAINTAINER= jwb@FreeBSD.org
@@ -10,7 +9,7 @@ WWW= https://github.com/outpaddling/freebsd-update-notify
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= zenity:x11/zenity auto-admin:sysutils/auto-admin
+RUN_DEPENDS= zenity:x11/zenity auto-admin>=0.7.18.3:sysutils/auto-admin
USE_GITHUB= yes
@@ -19,20 +18,26 @@ GH_ACCOUNT= outpaddling
NO_BUILD= yes
NO_ARCH= yes
+CONF_DIR= ${PREFIX}/etc/freebsd-update-notify
+
PLIST_FILES= libexec/freebsd-update-notify \
libexec/freebsd-update-cron \
man/man8/freebsd-update-notify.8.gz \
- "@sample etc/freebsd-update-notify.crontab.sample etc/cron.d/freebsd-update-notify" \
+ "@sample etc/freebsd-update-notify/freebsd-update-notify.conf.sample" \
+ "@sample etc/freebsd-update-notify/freebsd-update-notify.crontab.sample etc/cron.d/freebsd-update-notify" \
"@dir etc/cron.d"
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/cron.d
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/freebsd-update-notify
${INSTALL_SCRIPT} ${WRKSRC}/freebsd-update-notify \
${STAGEDIR}${PREFIX}/libexec
${INSTALL_SCRIPT} ${WRKSRC}/freebsd-update-cron \
${STAGEDIR}${PREFIX}/libexec
+ ${INSTALL_DATA} ${WRKSRC}/freebsd-update-notify.conf \
+ ${STAGEDIR}${CONF_DIR}/freebsd-update-notify.conf.sample
${INSTALL_DATA} ${WRKSRC}/freebsd-update-notify.crontab \
- ${STAGEDIR}${PREFIX}/etc/freebsd-update-notify.crontab.sample
+ ${STAGEDIR}${CONF_DIR}/freebsd-update-notify.crontab.sample
${INSTALL_MAN} ${WRKSRC}/freebsd-update-notify.8 \
${STAGEDIR}${MANPREFIX}/man/man8