aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-documents/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-documents/Makefile')
-rw-r--r--deskutils/gnome-documents/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/deskutils/gnome-documents/Makefile b/deskutils/gnome-documents/Makefile
index 071d25700bb8..3c6250ac153d 100644
--- a/deskutils/gnome-documents/Makefile
+++ b/deskutils/gnome-documents/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gnome-documents
-PORTVERSION= 3.18.2
-PORTREVISION= 3
+PORTVERSION= 3.24.2
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -12,34 +11,29 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Document manager application designed to work with GNOME 3
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= itstool:textproc/itstool \
docbook-xsl>=0:textproc/docbook-xsl
-LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
+LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
- libclutter-1.0.so:graphics/clutter \
- libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
libevview3.so:graphics/evince \
libgdata.so:devel/libgdata \
libgoa-1.0.so:net/gnome-online-accounts \
libgjs.so:lang/gjs \
libtracker-sparql-1.0.so:sysutils/tracker \
+ libgepub.so:textproc/libgepub \
libzapojit-0.0.so:net/libzapojit
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
- ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss \
- unoconv:textproc/unoconv
+RUN_DEPENDS= gnome-online-miners>=0:net/gnome-online-miners
PORTSCOUT= limitw:1,even
-USES= compiler:c++11-lib gettext gmake gnome libtool pathfix \
- pkgconfig python:2.7 tar:xz
-USE_GNOME= gnomedesktop3 gtk30 intlhack \
- introspection:build librsvg2 libxml2
+USES= compiler:c++11-lib gettext gmake gnome libtool localbase \
+ pathfix pkgconfig tar:xz
+USE_GNOME= cairo gdkpixbuf2 gnomedesktop3 intltool introspection librsvg2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.gnome.Documents.enums.xml \