aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-weather/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-weather/Makefile')
-rw-r--r--deskutils/gnome-weather/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/deskutils/gnome-weather/Makefile b/deskutils/gnome-weather/Makefile
new file mode 100644
index 000000000000..9d34b2e90e61
--- /dev/null
+++ b/deskutils/gnome-weather/Makefile
@@ -0,0 +1,27 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/deskutils/gnome-weather/Makefile 19994 2014-10-19 08:07:16Z gusi $
+
+PORTNAME= gnome-weather
+PORTVERSION= 3.14.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Weather application for GNOME 3
+
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+LIB_DEPENDS= libgweather-3.so:${PORTSDIR}/net/libgweather \
+ libgjs.so:${PORTSDIR}/lang/gjs
+
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+GLIB_SCHEMAS= org.gnome.Weather.Application.gschema.xml
+
+.include <bsd.port.mk>