aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gucharmap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gucharmap/Makefile')
-rw-r--r--deskutils/gucharmap/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/deskutils/gucharmap/Makefile b/deskutils/gucharmap/Makefile
index 3e7b22b93767..202c38a2476a 100644
--- a/deskutils/gucharmap/Makefile
+++ b/deskutils/gucharmap/Makefile
@@ -1,25 +1,25 @@
-# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
-
PORTNAME= gucharmap
-PORTVERSION= 13.0.8
+PORTVERSION= 15.1.0 # must sync with textproc/UCD
+PORTREVISION= 1
CATEGORIES= deskutils gnome
#MASTER_SITES= GNOME
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Unicode/ISO10646 character map and font viewer
+WWW= https://wiki.gnome.org/Gucharmap
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= itstool:textproc/itstool \
- UCD>=0:textproc/UCD \
- ${LOCALBASE}/share/aclocal/yelp.m4:textproc/yelp-tools \
- vala>=0.16:lang/vala
-LIB_DEPENDS= libfreetype.so:print/freetype2
+ UCD=${PORTVERSION},1:textproc/UCD \
+ ${LOCALBASE}/share/aclocal/yelp.m4:textproc/yelp-tools
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libpcre2-8.so:devel/pcre2
USES= desktop-file-utils gettext-tools gnome localbase meson perl5 pkgconfig \
- python:build tar:xz
+ python:build tar:xz vala:build
USE_GNOME= cairo glib20 gtk30 introspection:build
USE_PERL5= build
BINARY_ALIAS= python3=${PYTHON_CMD}
@@ -29,12 +29,9 @@ MESON_ARGS= -Ducd_path=${LOCALBASE}/share/unicode/ucd/
USE_GITLAB= yes
GL_SITE= https://gitlab.gnome.org
GL_ACCOUNT= GNOME
-GL_COMMIT= cdbc989f552833ea4ac0f8fefd095ebf6d61333e
GLIB_SCHEMAS= org.gnome.Charmap.gschema.xml
-PORTSCOUT= limitw:1,even
-
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes