aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kcharselect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/kcharselect/Makefile')
-rw-r--r--deskutils/kcharselect/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index 0a7c286315db..9a66faa99cad 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -33,6 +33,9 @@ MAKE_JOBS_SAFE= yes
MAN1= ark.1
+# Disable printer-applet, it comes with print/kdeutils4-printer-applet.
+CMAKE_ARGS+= -DBUILD_printer-applet=OFF
+
OPTIONS= 7ZIP "Support for 7-Zip archives in Ark" off \
PRINTER_APPLET "Install printer system tray utility" off \
RAR "Support for RAR archives in Ark" off \
@@ -76,9 +79,4 @@ RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar
.endif
.endif
-post-patch:
-# Disable printer-applet, it comes with print/kdeutils4-printer-applet.
- ${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
- ${PATCH_WRKSRC}/CMakeLists.txt
-
.include <bsd.port.post.mk>