aboutsummaryrefslogtreecommitdiff
path: root/deskutils/launchy
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/launchy')
-rw-r--r--deskutils/launchy/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/deskutils/launchy/Makefile b/deskutils/launchy/Makefile
index 59337ad3cf12..64cfc7bfc6eb 100644
--- a/deskutils/launchy/Makefile
+++ b/deskutils/launchy/Makefile
@@ -13,12 +13,13 @@ COMMENT= Open source keystroke launcher
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/bin/xdg-open:${PORTSDIR}/devel/xdg-utils
+USES= qmake
USE_DOS2UNIX= readme.lyx readme.txt
USE_QT4= qmake_build moc_build rcc_build uic_build gui network
PORTDOCS= *
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
+
.include <bsd.port.options.mk>
post-patch:
@@ -31,14 +32,10 @@ post-patch:
${WRKSRC}/plugins/weby/weby.pro \
${WRKSRC}/src/src.pro
-do-configure:
- @(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} -r Launchy.pro)
-
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/?eadme.* ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/?eadme.* ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>