aboutsummaryrefslogtreecommitdiff
path: root/deskutils/owncloudclient/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/owncloudclient/Makefile')
-rw-r--r--deskutils/owncloudclient/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index b9b423e9d79f..15a033c33f44 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -1,29 +1,33 @@
-# Created by: Mathieu Arnold
-
PORTNAME= owncloudclient
DISTVERSION= 2.8.2
DISTVERSIONSUFFIX= .4246
+PORTREVISION= 4
CATEGORIES= deskutils
MASTER_SITES= https://download.owncloud.com/desktop/ownCloud/stable/${DISTVERSION}${DISTVERSIONSUFFIX}/source/
DISTNAME= ownCloud-${DISTVERSION}${DISTVERSIONSUFFIX}
+PATCH_SITES= https://github.com/owncloud/client/commit/
+PATCHFILES= ff43c9394b45dd78106069ba89ae92f25abba158.patch:-p1
+
MAINTAINER= daniel@morante.net
COMMENT= OwnCloud Desktop Syncing Client
+WWW= https://github.com/owncloud/client
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libinotify.so:devel/libinotify \
- libqt5keychain.so:security/qtkeychain
+ libqt5keychain.so:security/qtkeychain@qt5
USES= cmake:noninja compiler:c++11-lib desktop-file-utils gmake \
iconv kde:5 localbase:ldflags pkgconfig qt:5 shared-mime-info \
sqlite tar:xz
USE_KDE= completion config coreaddons jobwidgets kio service \
- widgetsaddons windowsystem
+ widgetsaddons windowsystem \
+ ecm:build
USE_LDCONFIG= yes
-USE_QT= concurrent core dbus gui network sql webkit widgets xml \
- buildtools_build linguist_build qmake_build
+USE_QT= concurrent core dbus gui network sql widgets xml \
+ buildtools:build linguist:build qmake:build
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR:STRING=man \
-DSYSCONF_INSTALL_DIR="${PREFIX}/etc"