aboutsummaryrefslogtreecommitdiff
path: root/deskutils/sysctlview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/sysctlview/Makefile')
-rw-r--r--deskutils/sysctlview/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/deskutils/sysctlview/Makefile b/deskutils/sysctlview/Makefile
index e9b6c135e699..b3eac2e0db8e 100644
--- a/deskutils/sysctlview/Makefile
+++ b/deskutils/sysctlview/Makefile
@@ -1,9 +1,11 @@
PORTNAME= sysctlview
PORTVERSION= 2.1
+PORTREVISION= 4
CATEGORIES= deskutils
MAINTAINER= alfix86@gmail.com
COMMENT= Graphical sysctl MIB explorer
+WWW= https://gitlab.com/alfix/sysctlview/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -14,12 +16,10 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
USES= compiler:c++11-lang gnome pkgconfig
USE_GITLAB= yes
GL_ACCOUNT= alfix
-GL_COMMIT= 6ef5c821f66d92c2a1ca3fc964b511425dacd18e
+GL_TAGNAME= 6ef5c821f66d92c2a1ca3fc964b511425dacd18e
USE_GNOME= atk atkmm cairo cairomm gdkpixbuf2 glib20 glibmm gtk30 gtkmm30 \
libsigc++20 pango pangomm
-INSTALLS_ICONS= yes
-
DESKTOP_ENTRIES= "Sysctlview" \
"Show and set the kernel state" \
"sysctlview" \
@@ -29,16 +29,13 @@ DESKTOP_ENTRIES= "Sysctlview" \
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200019
-IGNORE= needs oid_label member of struct sysctl_oid defined in sysctl.h which was first introduced in FreeBSD 12
-.endif
.if ${OPSYS} != FreeBSD
IGNORE= not supported on anything but FreeBSD
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sysctlview ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/sysctlview.1 ${STAGEDIR}${MAN1PREFIX}/share/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/sysctlview.1 ${STAGEDIR}${PREFIX}/share/man/man1
.for i in 16 22 24 32 36 48 64 72 96 128 192 256
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps/
${INSTALL_DATA} ${WRKSRC}/icon/sysctlview-${i}.png \