aboutsummaryrefslogtreecommitdiff
path: root/deskutils/treesheets/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/treesheets/files/patch-CMakeLists.txt')
-rw-r--r--deskutils/treesheets/files/patch-CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/deskutils/treesheets/files/patch-CMakeLists.txt b/deskutils/treesheets/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..615468cb42c2
--- /dev/null
+++ b/deskutils/treesheets/files/patch-CMakeLists.txt
@@ -0,0 +1,25 @@
+--- CMakeLists.txt.orig 2024-03-24 04:56:12 UTC
++++ CMakeLists.txt
+@@ -95,11 +95,11 @@ target_link_libraries(
+
+ ########## TREESHEETS INSTALLATION SETTINGS ###############
+
+-if(LINUX)
++if(LINUX OR BSD)
+ OPTION(TREESHEETS_RELOCATABLE_INSTALLATION "Install data relative to the treesheets binary, instead of respecting the Filesystem Hierarchy Standard" OFF)
+ endif()
+
+-if(LINUX AND NOT TREESHEETS_RELOCATABLE_INSTALLATION)
++if((LINUX OR BSD) AND NOT TREESHEETS_RELOCATABLE_INSTALLATION)
+ include(GNUInstallDirs)
+
+ set(TREESHEETS_BINDIR ${CMAKE_INSTALL_BINDIR})
+@@ -125,7 +125,7 @@ install(FILES TS/readme.html DESTINATION ${TREESHEETS_
+ install(TARGETS treesheets DESTINATION ${TREESHEETS_BINDIR})
+ install(DIRECTORY TS/docs DESTINATION ${TREESHEETS_DOCDIR})
+ install(FILES TS/readme.html DESTINATION ${TREESHEETS_DOCDIR})
+-install(DIRECTORY TS/examples DESTINATION ${TREESHEETS_DOCDIR})
++install(DIRECTORY TS/examples DESTINATION ${CMAKE_INSTALL_DATADIR}/examples/${CMAKE_PROJECT_NAME})
+
+ install(DIRECTORY TS/images DESTINATION ${TREESHEETS_PKGDATADIR})
+ install(DIRECTORY TS/scripts DESTINATION ${TREESHEETS_PKGDATADIR})