aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-future
diff options
context:
space:
mode:
Diffstat (limited to 'devel/R-cran-future')
-rw-r--r--devel/R-cran-future/Makefile21
-rw-r--r--devel/R-cran-future/distinfo3
-rw-r--r--devel/R-cran-future/pkg-descr15
3 files changed, 39 insertions, 0 deletions
diff --git a/devel/R-cran-future/Makefile b/devel/R-cran-future/Makefile
new file mode 100644
index 000000000000..4b25a34e5599
--- /dev/null
+++ b/devel/R-cran-future/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= future
+DISTVERSION= 1.33.2
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= eduardo@FreeBSD.org
+COMMENT= Unified Parallel and Distributed Processing in R for Everyone
+WWW= https://cran.r-project.org/web/packages/future/
+
+LICENSE= LGPL21+
+
+CRAN_DEPENDS= R-cran-digest>0:security/R-cran-digest \
+ R-cran-globals>=0.16.1:devel/R-cran-globals \
+ R-cran-listenv>=0.8.0:devel/R-cran-listenv \
+ R-cran-parallelly>=1.34.0:devel/R-cran-parallelly
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-future/distinfo b/devel/R-cran-future/distinfo
new file mode 100644
index 000000000000..7ce30de404d5
--- /dev/null
+++ b/devel/R-cran-future/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1711529208
+SHA256 (future_1.33.2.tar.gz) = b5a71ac628cdaeeb26e3fc41003d2c5bd48156da881cabd9b14878991324aa66
+SIZE (future_1.33.2.tar.gz) = 355510
diff --git a/devel/R-cran-future/pkg-descr b/devel/R-cran-future/pkg-descr
new file mode 100644
index 000000000000..c75805cfe643
--- /dev/null
+++ b/devel/R-cran-future/pkg-descr
@@ -0,0 +1,15 @@
+The purpose of this package is to provide a lightweight and unified
+Future API for sequential and parallel processing of R expression
+via futures. The simplest way to evaluate an expression in parallel
+is to use 'x %<-% { expression }' with 'plan(multisession)'. This
+package implements sequential, multicore, multisession, and cluster
+futures. With these, R expressions can be evaluated on the local
+machine, in parallel a set of local machines, or distributed on a
+mix of local and remote machines. Extensions to this package implement
+additional backends for processing futures via compute cluster
+schedulers, etc. Because of its unified API, there is no need to
+modify any code in order switch from sequential on the local machine
+to, say, distributed processing on a remote compute cluster. Another
+strength of this package is that global variables and functions are
+automatically identified and exported as needed, making it
+straightforward to tweak existing code to make use of futures.