aboutsummaryrefslogtreecommitdiff
path: root/devel/ammonite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ammonite/Makefile')
-rw-r--r--devel/ammonite/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/ammonite/Makefile b/devel/ammonite/Makefile
new file mode 100644
index 000000000000..8e0120c5aff7
--- /dev/null
+++ b/devel/ammonite/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= ammonite
+DISTVERSION= 2.5.11
+CATEGORIES= devel java
+MASTER_SITES= https://github.com/lihaoyi/Ammonite/releases/download/${PORTVERSION}/
+DISTNAME= 3.2-${PORTVERSION}
+EXTRACT_SUFX=
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY=
+
+MAINTAINER= freebsd-ports@jan0sch.de
+COMMENT= Provides a system shell in the high-level Scala language
+WWW= https://ammonite.io/
+
+LICENSE= MIT
+
+USE_JAVA= yes
+JAVA_VERSION= 8+
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/ammonite
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>