aboutsummaryrefslogtreecommitdiff
path: root/devel/arcanist-lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/arcanist-lib/Makefile')
-rw-r--r--devel/arcanist-lib/Makefile45
1 files changed, 22 insertions, 23 deletions
diff --git a/devel/arcanist-lib/Makefile b/devel/arcanist-lib/Makefile
index b73e2d8f8a7d..b5ffbe608260 100644
--- a/devel/arcanist-lib/Makefile
+++ b/devel/arcanist-lib/Makefile
@@ -1,51 +1,49 @@
PORTNAME?= arcanist
-PORTVERSION?= 20210113
+PORTVERSION?= 20220518
+PORTREVISION?= 5
CATEGORIES?= devel
PKGNAMESUFFIX= ${SLAVE_PKGNAMESUFFIX}${PHP_PKGNAMESUFFIX}
MAINTAINER= grembo@FreeBSD.org
COMMENT?= Libraries for the command line interface for Phabricator
-
-SLAVEPORT?= lib
+WWW?= https://secure.phabricator.com/book/arcanist/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-PHP_DESTDIR= lib/php/arcanist
USES= php:cli,flavors python:env shebangfix
-SHEBANG_FILES= bin/arc \
- bin/phage \
- scripts/*.php \
- scripts/hgdaemon/*.php \
- src/parser/*.php \
- support/arcanoid/arcanoid.py \
- support/lib/*.php \
- support/unit/*.php \
- support/xhpast/*.php \
+USE_GITHUB= yes
+GH_ACCOUNT= phacility
+GH_TAGNAME= 85c953e
+USE_PHP= curl dom simplexml zlib
+
+SHEBANG_FILES= bin/arc bin/phage scripts/*.php scripts/hgdaemon/*.php \
+ src/parser/*.php support/arcanoid/arcanoid.py support/lib/*.php \
+ support/unit/*.php support/xhpast/*.php \
support/xhpast/bin/*.php
-USE_PHP= curl dom hash json simplexml zlib
-USE_GITHUB= yes
-NO_BUILD= yes
NO_ARCH= yes
+NO_BUILD= yes
PORTSCOUT= ignore:1
-GH_ACCOUNT= phacility
-GH_TAGNAME= b2e715f
+SLAVEPORT?= lib
+
PLIST= ${.CURDIR}/pkg-plist
+PHP_DESTDIR= lib/php/arcanist
+
.if ${SLAVEPORT} == lib
SLAVE_PKGNAMESUFFIX= -${SLAVEPORT}
-OPTIONS_DEFINE= ENCODINGS
-OPTIONS_DEFAULT=ENCODINGS
-ENCODINGS_DESC= Support for encodings other than utf-8
-ENCODINGS_USE= PHP=mbstring
+OPTIONS_DEFINE= ENCODINGS
+OPTIONS_DEFAULT= ENCODINGS
+ENCODINGS_DESC= Support for encodings other than utf-8
+ENCODINGS_USE= PHP=mbstring
.else # link only
RUN_DEPENDS= arcanist-lib${PHP_PKGNAMESUFFIX}>0:devel/arcanist-lib@${PHP_FLAVOR}
-CONFLICTS= arc
+CONFLICTS= arc arcanist-php??
PLIST_FILES= bin/arc
@@ -78,6 +76,7 @@ do-install:
@${REINPLACE_CMD} \
's|%%PYTHON_CMD%%|${PYTHON_CMD}|g' \
${STAGEDIR}${PREFIX}/${PHP_DESTDIR}/src/workflow/ArcanistAnoidWorkflow.php
+ ${RM} ${STAGEDIR}${PREFIX}/${PHP_DESTDIR}/resources/ssl/default.pem
${RLN} ${STAGEDIR}${PREFIX}/${PHP_DESTDIR}/support/shell/hooks/bash-completion.sh \
${STAGEDIR}${PREFIX}/share/bash-completion/completions/arc
${STAGEDIR}${PREFIX}/${PHP_DESTDIR}/bin/arc shell-complete --generate