aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc-3/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/avr-gcc-3/files')
-rw-r--r--devel/avr-gcc-3/files/patch-16bitassign13
-rw-r--r--devel/avr-gcc-3/files/patch-aa12
-rw-r--r--devel/avr-gcc-3/files/patch-ab90
-rw-r--r--devel/avr-gcc-3/files/patch-ac12
-rw-r--r--devel/avr-gcc-3/files/patch-ad12
-rw-r--r--devel/avr-gcc-3/files/patch-no-c++-excepts20
6 files changed, 0 insertions, 159 deletions
diff --git a/devel/avr-gcc-3/files/patch-16bitassign b/devel/avr-gcc-3/files/patch-16bitassign
deleted file mode 100644
index 6a5659c18290..000000000000
--- a/devel/avr-gcc-3/files/patch-16bitassign
+++ /dev/null
@@ -1,13 +0,0 @@
---- gcc/config/avr/avr.c.orig Mon Aug 12 15:13:56 2002
-+++ gcc/config/avr/avr.c Thu Aug 29 12:53:14 2002
-@@ -2711,8 +2711,8 @@
- }
- }
- else
-- return *l=2, (AS2 (st ,%0,%A1) CR_TAB
-- AS2 (std,%0+1,%B1));
-+ return *l=2, (AS2 (std,%0+1,%B1) CR_TAB
-+ AS2 (st ,%0,%A1));
- }
- else if (GET_CODE (base) == PLUS)
- {
diff --git a/devel/avr-gcc-3/files/patch-aa b/devel/avr-gcc-3/files/patch-aa
deleted file mode 100644
index d8682e145771..000000000000
--- a/devel/avr-gcc-3/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- libiberty/Makefile.in.orig Tue Jan 22 21:03:29 2002
-+++ libiberty/Makefile.in Tue Jun 4 18:19:26 2002
-@@ -234,7 +234,8 @@
- @MAINT@ echo stamp > stamp-functions
-
- INSTALL_DEST = @INSTALL_DEST@
--install: install_to_$(INSTALL_DEST) install-subdir
-+#install: install_to_$(INSTALL_DEST) install-subdir
-+install:
-
- install_to_libdir: all
- $(INSTALL_DATA) $(TARGETLIB) $(libdir)$(MULTISUBDIR)/$(TARGETLIB)n
diff --git a/devel/avr-gcc-3/files/patch-ab b/devel/avr-gcc-3/files/patch-ab
deleted file mode 100644
index c20f2aa1c9c7..000000000000
--- a/devel/avr-gcc-3/files/patch-ab
+++ /dev/null
@@ -1,90 +0,0 @@
---- Makefile.in.orig Mon Aug 12 15:13:39 2002
-+++ Makefile.in Mon Aug 12 15:31:13 2002
-@@ -186,7 +186,7 @@
-
- # This is set by the configure script to the list of directories which
- # should be built using the target tools.
--TARGET_CONFIGDIRS = libiberty libgloss $(SPECIAL_LIBS) newlib winsup opcodes libf2c libobjc
-+TARGET_CONFIGDIRS = libgloss $(SPECIAL_LIBS) newlib winsup opcodes
-
- # Target libraries are put under this directory:
- # Changed by configure to $(target_alias) if cross.
-@@ -755,74 +755,19 @@
-
- # This is a list of the targets for all of the modules which are compiled
- # using $(TARGET_FLAGS_TO_PASS).
--ALL_TARGET_MODULES = \
-- all-target-libstdc++-v3 \
-- all-target-newlib \
-- all-target-libf2c \
-- all-target-libobjc \
-- all-target-libtermcap \
-- all-target-winsup \
-- all-target-libgloss \
-- all-target-libiberty \
-- all-target-gperf \
-- all-target-examples \
-- all-target-libffi \
-- all-target-libjava \
-- all-target-zlib \
-- all-target-boehm-gc \
-- all-target-qthreads
-+ALL_TARGET_MODULES =
-
- # This is a list of the configure targets for all of the modules which
- # are compiled using the target tools.
--CONFIGURE_TARGET_MODULES = \
-- configure-target-libstdc++-v3 \
-- configure-target-newlib \
-- configure-target-libf2c \
-- configure-target-libobjc \
-- configure-target-libtermcap \
-- configure-target-winsup \
-- configure-target-libgloss \
-- configure-target-libiberty \
-- configure-target-gperf \
-- configure-target-examples \
-- configure-target-libffi \
-- configure-target-libjava \
-- configure-target-zlib \
-- configure-target-boehm-gc \
-- configure-target-qthreads
-+CONFIGURE_TARGET_MODULES =
-
- # This is a list of the check targets for all of the modules which are
- # compiled using $(TARGET_FLAGS_TO_PASS).
--CHECK_TARGET_MODULES = \
-- check-target-libstdc++-v3 \
-- check-target-newlib \
-- check-target-libf2c \
-- check-target-libobjc \
-- check-target-winsup \
-- check-target-libiberty \
-- check-target-libffi \
-- check-target-libjava \
-- check-target-zlib \
-- check-target-boehm-gc \
-- check-target-qthreads \
-- check-target-gperf
-+CHECK_TARGET_MODULES =
-
- # This is a list of the install targets for all of the modules which are
- # compiled using $(TARGET_FLAGS_TO_PASS).
--INSTALL_TARGET_MODULES = \
-- install-target-libstdc++-v3 \
-- install-target-newlib \
-- install-target-libf2c \
-- install-target-libobjc \
-- install-target-libtermcap \
-- install-target-winsup \
-- install-target-libgloss \
-- install-target-libiberty \
-- install-target-libjava \
-- install-target-zlib \
-- install-target-boehm-gc \
-- install-target-qthreads \
-- install-target-gperf
-+INSTALL_TARGET_MODULES =
-
- # This is a list of the targets for which we can do a clean-{target}.
- CLEAN_MODULES = \
diff --git a/devel/avr-gcc-3/files/patch-ac b/devel/avr-gcc-3/files/patch-ac
deleted file mode 100644
index cec083e3ee83..000000000000
--- a/devel/avr-gcc-3/files/patch-ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.in.orig Sun May 5 20:56:48 2002
-+++ configure.in Tue Jun 4 18:21:31 2002
-@@ -706,6 +706,9 @@
- target_configdirs="${target_configdirs} target-bsp target-cygmon"
- fi
- ;;
-+ avr-*-*)
-+ noconfigdirs="$noconfigdirs ${libstdcxx_version} target-libglosstarget-libiberty"
-+ ;;
- arm-*-oabi*)
- noconfigdirs="$noconfigdirs target-libgloss ${libgcj}"
- ;;
diff --git a/devel/avr-gcc-3/files/patch-ad b/devel/avr-gcc-3/files/patch-ad
deleted file mode 100644
index 52f922b28531..000000000000
--- a/devel/avr-gcc-3/files/patch-ad
+++ /dev/null
@@ -1,12 +0,0 @@
---- gcc/cp/Make-lang.in.orig Tue Jun 4 09:09:54 2002
-+++ gcc/cp/Make-lang.in Mon Jun 17 23:16:10 2002
-@@ -50,7 +50,8 @@
- DEMANGLER_CROSS_NAME = `echo c++filt|sed '$(program_transform_cross_name)'`
-
- # The name to use for the demangler program.
--DEMANGLER_PROG = c++filt$(exeext)
-+#DEMANGLER_PROG = c++filt$(exeext)
-+DEMANGLER_PROG =
-
- #
- # Define the names for selecting c++ in LANGUAGES.
diff --git a/devel/avr-gcc-3/files/patch-no-c++-excepts b/devel/avr-gcc-3/files/patch-no-c++-excepts
deleted file mode 100644
index d738b8228f20..000000000000
--- a/devel/avr-gcc-3/files/patch-no-c++-excepts
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: gcc/config/avr/avr.h
-===================================================================
-RCS file: /cvsroot/gcc/gcc/gcc/config/avr/avr.h,v
-retrieving revision 1.66
-diff -u -r1.66 avr.h
---- gcc/config/avr/avr.h 11 Aug 2002 18:48:50 -0000 1.66
-+++ gcc/config/avr/avr.h 28 Aug 2002 21:12:06 -0000
-@@ -2523,6 +2523,12 @@
-
- Do not define this macro if it does not need to do anything. */
-
-+#define CC1PLUS_SPEC "%{!frtti:-fno-rtti} \
-+ %{!fenforce-eh-specs:-fno-enforce-eh-specs} \
-+ %{!fexceptions:-fno-exceptions}"
-+/* A C string constant that tells the GNU CC drvier program options to
-+ pass to `cc1plus'. */
-+
- #define ASM_SPEC "%{mmcu=*:-mmcu=%*}"
- /* A C string constant that tells the GNU CC driver program options to
- pass to the assembler. It can also specify how to translate