aboutsummaryrefslogtreecommitdiff
path: root/devel/ayatana-ido/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ayatana-ido/Makefile')
-rw-r--r--devel/ayatana-ido/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/devel/ayatana-ido/Makefile b/devel/ayatana-ido/Makefile
index 348ed1e82de3..bf7242e74bbc 100644
--- a/devel/ayatana-ido/Makefile
+++ b/devel/ayatana-ido/Makefile
@@ -1,28 +1,35 @@
PORTNAME= ayatana-ido
-PORTVERSION= 0.9.2
-PORTREVISION= 2
+PORTVERSION= 0.10.2
CATEGORIES= devel
MAINTAINER= jgh@FreeBSD.org
COMMENT= Ayatana Indicator Display Objects
+WWW= https://github.com/AyatanaIndicators/ayatana-ido
LICENSE= LGPL3
-LIB_DEPENDS= libharfbuzz.so:print/harfbuzz \
- libgtest.so:devel/googletest
-BUILD_DEPENDS= vala>=0:lang/vala \
- lcov>=0:devel/lcov
+LIB_DEPENDS= libgtest.so:devel/googletest \
+ libharfbuzz.so:print/harfbuzz
+BUILD_DEPENDS= lcov>=0:devel/lcov
-USES= cmake localbase:ldflags gnome pkgconfig
-
-USE_GNOME= introspection glib20 gtk30 pango atk cairo gdkpixbuf2
+USES= cmake gnome localbase:ldflags pkgconfig vala:build
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 introspection pango
+OPTIONS_DEFINE= DOCS
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= AyatanaIndicators
+PORTDOCS= AUTHORS ChangeLog INSTALL.md NEWS README.md
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libayatana-ido3-0.4.so.*
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+
.include <bsd.port.mk>