aboutsummaryrefslogtreecommitdiff
path: root/devel/bear/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/bear/Makefile')
-rw-r--r--devel/bear/Makefile35
1 files changed, 22 insertions, 13 deletions
diff --git a/devel/bear/Makefile b/devel/bear/Makefile
index b7dcd5857eea..1339f02a0675 100644
--- a/devel/bear/Makefile
+++ b/devel/bear/Makefile
@@ -1,33 +1,42 @@
# Created by: Jov <amutu@amutu.com>
PORTNAME= bear
-DISTVERSION= 2.4.4
+DISTVERSION= 3.0.13
CATEGORIES= devel
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jrm@FreeBSD.org
COMMENT= Tool that generates a compilation database for clang tooling
-LICENSE= GPLv3
+LICENSE= GPLv3+
-USES= cmake python shebangfix
+BUILD_DEPENDS= nlohmann-json>0:devel/nlohmann-json
+LIB_DEPENDS= libabsl_hash.so:devel/abseil \
+ libcares.so:dns/c-ares \
+ libfmt.so:devel/libfmt \
+ libgrpc.so:devel/grpc \
+ libprotobuf.so:devel/protobuf \
+ libre2.so:devel/re2 \
+ libspdlog.so:devel/spdlog
+
+USES= cmake compiler:c++17-lang pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= rizsotto
GH_PROJECT= Bear
USE_LDCONFIG= yes
-SHEBANG_FILES= bear/bear.py
-python_OLD_CMD= "/usr/bin/env @BEAR_PYTHON_EXECUTABLE@"
+CMAKE_ARGS= -DCMAKE_INSTALL_DOCDIR=${DOCSDIR} \
+ -DENABLE_FUNC_TESTS=OFF \
+ -DENABLE_UNIT_TESTS=OFF
OPTIONS_DEFINE= DOCS
-post-patch:
- ${REINPLACE_CMD} -e '/install(FILES COPYING/d' \
- -e '/{CMAKE_INSTALL_DOCDIR}/d' \
- ${WRKSRC}/CMakeLists.txt
+pre-install:
+ ${MV} ${STAGEDIR}/${CONFIGURE_WRKSRC}/stage ${CONFIGURE_WRKSRC}/
+ ${RM} -r ${STAGEDIR}/wrkdirs
-post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+post-install:
+.for l in bin/citnames bin/intercept libexec/bear/libexec.so libexec/bear/wrapper
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${l}
+.endfor
.include <bsd.port.mk>