aboutsummaryrefslogtreecommitdiff
path: root/devel/bison175
diff options
context:
space:
mode:
Diffstat (limited to 'devel/bison175')
-rw-r--r--devel/bison175/Makefile32
-rw-r--r--devel/bison175/distinfo1
-rw-r--r--devel/bison175/files/patch-getargs.c18
-rw-r--r--devel/bison175/files/patch-reader.c22
-rw-r--r--devel/bison175/pkg-comment1
-rw-r--r--devel/bison175/pkg-descr22
-rw-r--r--devel/bison175/pkg-plist14
7 files changed, 0 insertions, 110 deletions
diff --git a/devel/bison175/Makefile b/devel/bison175/Makefile
deleted file mode 100644
index 27bb047f98f6..000000000000
--- a/devel/bison175/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: bison
-# Date created: 27 Mar 1999
-# Whom: Jerry Hicks
-#
-# $FreeBSD$
-#
-
-PORTNAME= bison
-PORTVERSION= 1.28
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= bison
-
-MAINTAINER= wghicks@bellsouth.net
-MAINTAINER= obrien@NUXI.com
-
-LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
-
-MAN1= bison.1
-
-post-install:
- @if [ ! -f ${PREFIX}/info/dir ]; then \
- ${SED} -ne '1,/Menu:/p' \/usr\/share\/info/dir > ${PREFIX}/info/dir; \
- fi
- @install-info ${PREFIX}/info/bison.info ${PREFIX}/info/dir
-
-.include <bsd.port.mk>
diff --git a/devel/bison175/distinfo b/devel/bison175/distinfo
deleted file mode 100644
index bf42a21c5426..000000000000
--- a/devel/bison175/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (bison-1.28.tar.gz) = 4afb3989f2270043c47c3daa1fa7ffab
diff --git a/devel/bison175/files/patch-getargs.c b/devel/bison175/files/patch-getargs.c
deleted file mode 100644
index a08818ef5ca3..000000000000
--- a/devel/bison175/files/patch-getargs.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/getargs.c.orig Mon Jun 14 15:19:05 1999
-+++ src/getargs.c Mon Jan 17 03:38:56 2000
-@@ -31,6 +31,7 @@
- int noparserflag = 0;
- int toknumflag = 0;
- int rawtoknumflag = 0;
-+int broken_undeftoken_init;
- char *spec_name_prefix; /* for -p. */
- char *spec_file_prefix; /* for -b. */
- extern int fixed_outfiles;/* for -y */
-@@ -44,6 +45,7 @@
-
- struct option longopts[] =
- {
-+ {"broken-undeftoken-init", 0, &broken_undeftoken_init, 1},
- {"debug", 0, &debugflag, 1},
- {"defines", 0, &definesflag, 1},
- {"file-prefix", 1, 0, 'b'},
diff --git a/devel/bison175/files/patch-reader.c b/devel/bison175/files/patch-reader.c
deleted file mode 100644
index 29e1146a7e1d..000000000000
--- a/devel/bison175/files/patch-reader.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/reader.c.orig Mon Jun 14 15:19:05 1999
-+++ src/reader.c Mon Jan 17 03:38:56 2000
-@@ -44,6 +44,7 @@
- int rline_allocated;
-
- extern char *program_name;
-+extern int broken_undeftoken_init;
- extern int definesflag;
- extern int nolinesflag;
- extern int noparserflag;
-@@ -199,7 +200,10 @@
- /* it is always token number 2. */
- undeftoken = getsym("$undefined.");
- undeftoken->class = STOKEN;
-- undeftoken->user_token_number = 2;
-+ /* XXX ``broken_undeftoken_init'' makes Bison 1.28 bug-compatable
-+ with Bison 1.25. FreeBSD depends on this behavior when compiling
-+ EGCS-1.1.2's cc1plus. */
-+ undeftoken->user_token_number = broken_undeftoken_init ? 0 : 2;
- /* Read the declaration section. Copy %{ ... %} groups to ftable and fdefines file.
- Also notice any %token, %left, etc. found there. */
- if (noparserflag)
diff --git a/devel/bison175/pkg-comment b/devel/bison175/pkg-comment
deleted file mode 100644
index a0850f8a7b1f..000000000000
--- a/devel/bison175/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A parser generator from FSF, (mostly) compatible with Yacc
diff --git a/devel/bison175/pkg-descr b/devel/bison175/pkg-descr
deleted file mode 100644
index c968b052baf7..000000000000
--- a/devel/bison175/pkg-descr
+++ /dev/null
@@ -1,22 +0,0 @@
-Bison is a tool used to write parsers, such as the parser for GNU cc.
-It is similar to Yacc, which is included in the base FreeBSD system.
-
-The main difference between Bison and Yacc that I know of is that
-Bison supports the @N construction, which gives you access to
-the starting and ending line number and character number associated
-with any of the symbols in the current rule.
-
-Also, Bison supports the command `%expect N' which says not to mention
-the conflicts if there are N shift/reduce conflicts and no reduce/reduce
-conflicts.
-
-The differences in the algorithms stem mainly from the horrible
-kludges that Johnson had to perpetrate to make Yacc fit in a PDP-11.
-
-Also, Bison uses a faster but less space-efficient encoding for the
-parse tables (see Corbett's PhD thesis from Berkeley, "Static
-Semantics in Compiler Error Recovery", June 1985, Report No. UCB/CSD
-85/251), and more modern technique for generating the lookahead sets.
-(See "Efficient Construction of LALR(1) Lookahead Sets" by F. DeRemer
-and A. Pennello, in ACM TOPLS Vol 4 No 4, October 1982. Their
-technique is the standard one now.)
diff --git a/devel/bison175/pkg-plist b/devel/bison175/pkg-plist
deleted file mode 100644
index df2a354c2e07..000000000000
--- a/devel/bison175/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-@comment $FreeBSD$
-bin/bison
-share/bison.hairy
-share/bison.simple
-@unexec install-info --delete %D/info/bison.info %D/info/dir
-info/bison.info
-@exec install-info %D/info/bison.info %D/info/dir
-share/locale/de/LC_MESSAGES/bison.mo
-share/locale/es/LC_MESSAGES/bison.mo
-share/locale/fr/LC_MESSAGES/bison.mo
-share/locale/nl/LC_MESSAGES/bison.mo
-@unexec rmdir %D/share/locale/*/LC_MESSAGES 2>/dev/null || true
-@unexec rmdir %D/share/locale/* 2>/dev/null || true
-@unexec rmdir %D/share/locale 2>/dev/null || true