aboutsummaryrefslogtreecommitdiff
path: root/devel/capnproto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/capnproto/Makefile')
-rw-r--r--devel/capnproto/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/devel/capnproto/Makefile b/devel/capnproto/Makefile
index c02b3bcb0f68..c2e86eefb40d 100644
--- a/devel/capnproto/Makefile
+++ b/devel/capnproto/Makefile
@@ -1,5 +1,5 @@
PORTNAME= capnproto
-DISTVERSION= 0.10.1
+DISTVERSION= 1.0.2
CATEGORIES= devel
MASTER_SITES= https://capnproto.org/
DISTNAME= ${PORTNAME}-c++-${DISTVERSION}
@@ -11,14 +11,16 @@ WWW= https://capnproto.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake compiler:c++14-lang cpe pathfix ssl
+USES= cmake:testing compiler:c++14-lang cpe pathfix ssl
USE_LDCONFIG= yes
-CMAKE_ON= BUILD_SHARED_LIBS
-CMAKE_OFF= BUILD_TESTING
-
CONFLICTS_INSTALL= capnproto080
+CMAKE_TESTING_ON= BUILD_TESTING
+
PLIST_SUB= DISTVERSION="${DISTVERSION}"
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_TESTING
+
.include <bsd.port.mk>