aboutsummaryrefslogtreecommitdiff
path: root/devel/cargo-c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cargo-c/Makefile')
-rw-r--r--devel/cargo-c/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/cargo-c/Makefile b/devel/cargo-c/Makefile
index f566a1b6c581..af51a01bca37 100644
--- a/devel/cargo-c/Makefile
+++ b/devel/cargo-c/Makefile
@@ -1,7 +1,6 @@
PORTNAME= cargo-c
-DISTVERSION= 0.9.19
-DISTVERSIONSUFFIX= +cargo-0.70
-PORTREVISION= 1
+DISTVERSION= 0.9.20
+DISTVERSIONSUFFIX= +cargo-0.71
CATEGORIES= devel
MASTER_SITES= CRATESIO
# XXX Teach USES=cargo to have proper default
@@ -14,9 +13,7 @@ WWW= https://github.com/lu-zero/cargo-c
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libgit2.so:devel/libgit2 \
- libcurl.so:ftp/curl \
- libssh2.so:security/libssh2
+LIB_DEPENDS= libcurl.so:ftp/curl
USES= cargo ssl
PLIST_FILES= bin/cargo-capi \
@@ -28,5 +25,10 @@ PLIST_FILES= bin/cargo-capi \
post-patch:
@${REINPLACE_CMD} -e 's,libdir.join("pkgconfig,prefix.join("libdata/pkgconfig,' \
${WRKSRC}/src/install.rs
+# XXX Need devel/libgit2 >= 1.6.4; libgit2 depends on libssh2, so bundle both
+ @${REINPLACE_CMD} 's/if try_to_use_system_libgit2/if false/' \
+ ${WRKSRC}/cargo-crates/libgit2-sys-*/build.rs
+ @${REINPLACE_CMD} '/env::var/s/LIBSSH2.*PKG/disabled_&/' \
+ ${WRKSRC}/cargo-crates/libssh2-sys-*/build.rs
.include <bsd.port.mk>