aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake-doc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cmake-doc/Makefile')
-rw-r--r--devel/cmake-doc/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/devel/cmake-doc/Makefile b/devel/cmake-doc/Makefile
index 633b419209f0..16fd12e5e4bf 100644
--- a/devel/cmake-doc/Makefile
+++ b/devel/cmake-doc/Makefile
@@ -1,33 +1,33 @@
PORTNAME= cmake
-DISTVERSION= 3.20.5
+DISTVERSION= ${_CMAKE_VERSION}
CATEGORIES= devel
-MASTER_SITES= https://www.cmake.org/files/v${PORTVERSION:R}/
PKGNAMESUFFIX= -doc
MAINTAINER= kde@FreeBSD.org
COMMENT= HTML and Qt Creator helpfiles for CMake
+WWW= https://www.cmake.org
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/Copyright.txt
-BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
+BUILD_DEPENDS= sphinx-build:textproc/py-sphinx@${PY_FLAVOR}
-DISTINFO_FILE= ${.CURDIR}/../cmake/distinfo
-
-NO_ARCH= yes
-USES= cmake qt:5
-USE_QT= help_build
+USES= cmake python:build qt:6
USE_LOCALE= en_US.UTF-8
+USE_QT= sqldriver-sqlite:build tools:build
-CMAKE_OFF= SPHINX_MAN
-CMAKE_ON= SPHINX_HTML SPHINX_QTHELP
CMAKE_ARGS= -DCMAKE_DOC_DIR:STRING="${DOCSDIR_REL}" \
- -DQCOLLECTIONGENERATOR_EXECUTABLE=${QT_BINDIR}/qhelpgenerator
+ -DQHELPGENERATOR_EXECUTABLE=${QT_TOOLDIR}/qhelpgenerator
+CMAKE_ON= SPHINX_HTML SPHINX_QTHELP
+CMAKE_OFF= SPHINX_MAN
CMAKE_SOURCE_PATH= ${WRKSRC}/Utilities/Sphinx
ALL_TARGET= documentation
INSTALL_TARGET= install
+NO_ARCH= yes
+
+DISTINFO_FILE= ${.CURDIR}/../cmake-core/distinfo
PLIST_SUB= CMAKEVERSION="${DISTVERSION:S/.//g:C/-.*//}"
.include <bsd.port.mk>