aboutsummaryrefslogtreecommitdiff
path: root/devel/creduce/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/creduce/Makefile')
-rw-r--r--devel/creduce/Makefile47
1 files changed, 23 insertions, 24 deletions
diff --git a/devel/creduce/Makefile b/devel/creduce/Makefile
index e1d9811acfe0..84c04fb38c23 100644
--- a/devel/creduce/Makefile
+++ b/devel/creduce/Makefile
@@ -1,40 +1,39 @@
PORTNAME= creduce
-DISTVERSION= 2.10.0
+DISTVERSION= 2.11.0.llvm13.g20220117
+PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= http://embed.cs.utah.edu/creduce/
-MAINTAINER= swills@FreeBSD.org
+MAINTAINER= fuz@FreeBSD.org
COMMENT= Produces small test cases
+WWW= https://github.com/csmith-project/creduce
-LLVM_VER= 80
-BUILD_DEPENDS= llvm-config${LLVM_VER}:devel/llvm${LLVM_VER}
-RUN_DEPENDS= llvm-config${LLVM_VER}:devel/llvm${LLVM_VER} \
- topformflat:devel/delta \
- astyle:devel/astyle \
+LICENSE= NCSA
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
+LIB_DEPENDS= libzstd.so:archivers/zstd
+RUN_DEPENDS= topformflat:devel/delta \
p5-Benchmark-Timer>=0:devel/p5-Benchmark-Timer \
p5-Exporter-Lite>=0:devel/p5-Exporter-Lite \
p5-File-Which>=0:sysutils/p5-File-Which \
p5-Regexp-Common>=0:textproc/p5-Regexp-Common \
p5-Sys-CPU>=0:devel/p5-Sys-CPU \
- p5-Getopt-Tabular>=0:devel/p5-Getopt-Tabular
-
-BROKEN_FreeBSD_11_powerpc64= fails to configure: cannot compile and link test program with selected LLVM
-BROKEN_FreeBSD_12_powerpc64= fails to configure: cannot compile and link test program with selected LLVM
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config${LLVM_VER} \
- CC=${LOCALBASE}/bin/clang${LLVM_VER} \
- CXX=${LOCALBASE}/bin/clang++${LLVM_VER} \
- CPP=${LOCALBASE}/bin/clang-cpp${LLVM_VER}
+ p5-Getopt-Tabular>=0:devel/p5-Getopt-Tabular \
+ p5-Term-ReadKey>=0:devel/p5-Term-ReadKey
-USES= autoreconf gmake libtool perl5
+USES= cmake gnome compiler:c++14-lang llvm:13,build,lib,run perl5
-CFLAGS_powerpc64= -mabi=elfv2
+USE_CXXSTD= c++14
+USE_GITHUB= yes
+GH_ACCOUNT= csmith-project
+GH_TAGNAME= 4ae77d1e101135a6aea310b30c19e2af968b7bf6
+USE_GNOME= libxml2
-.include <bsd.port.options.mk>
+# See clang_delta/CMakeLists.txt for more details
+LDFLAGS+= -lLLVM-${LLVM_VERSION} -L${LLVM_PREFIX}/lib
-.if ${ARCH} == powerpc
-LLD_UNSAFE= yes
-.endif
+CMAKE_OFF= ENABLE_TRANS_ASSERT
+CMAKE_ARGS= -DLLVM_DIR=${LLVM_PREFIX}/lib/cmake/llvm \
+ -DClang_DIR=${LLVM_PREFIX}/lib/cmake/clang
.include <bsd.port.mk>