aboutsummaryrefslogtreecommitdiff
path: root/devel/date/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/date/Makefile')
-rw-r--r--devel/date/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/date/Makefile b/devel/date/Makefile
new file mode 100644
index 000000000000..cb7aabb59f19
--- /dev/null
+++ b/devel/date/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= date
+PORTVERSION= 3.0.1
+DISTVERSIONPREFIX= v
+PORTREVISION= 1
+CATEGORIES= devel
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Date and time library based on the C++11 (and beyond) <chrono> header
+WWW= https://github.com/HowardHinnant/date
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+USES= cmake compiler:c++17-lang
+
+CMAKE_OFF= COMPILE_WITH_C_LOCALE DISABLE_STRING_VIEW ENABLE_DATE_TESTING MANUAL_TZ_DB USE_SYSTEM_TZ_DB USE_TZ_DB_IN_DOT
+CMAKE_ON= BUILD_SHARED_LIBS BUILD_TZ_LIB
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= HowardHinnant
+GH_PROJECT= date
+
+.include <bsd.port.mk>