aboutsummaryrefslogtreecommitdiff
path: root/devel/dmlc-core/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/dmlc-core/Makefile')
-rw-r--r--devel/dmlc-core/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/devel/dmlc-core/Makefile b/devel/dmlc-core/Makefile
index dee6e22f06c6..a5f917e9105b 100644
--- a/devel/dmlc-core/Makefile
+++ b/devel/dmlc-core/Makefile
@@ -1,27 +1,24 @@
PORTNAME= dmlc-core
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3-123
-DISTVERSIONSUFFIX= -gb3a4c71
+DISTVERSION= 0.5-23
+DISTVERSIONSUFFIX= -ga355fbf
CATEGORIES= devel # machine-learning
MAINTAINER= yuri@FreeBSD.org
COMMENT= Common library for scalable and portable distributed machine learning
+WWW= https://github.com/dmlc/dmlc-core
LICENSE= APACHE20
-USES= cmake
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= dmlc
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == powerpc
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c++11-lang
+.if !exists(/usr/include/omp.h)
+CMAKE_ARGS+= -DUSE_OPENMP:BOOL=OFF
.endif
.include <bsd.port.mk>