aboutsummaryrefslogtreecommitdiff
path: root/devel/gbump/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gbump/Makefile')
-rw-r--r--devel/gbump/Makefile109
1 files changed, 63 insertions, 46 deletions
diff --git a/devel/gbump/Makefile b/devel/gbump/Makefile
index fff65d203bd0..06b15ff0972b 100644
--- a/devel/gbump/Makefile
+++ b/devel/gbump/Makefile
@@ -1,12 +1,13 @@
PORTNAME= gbump
-PORTVERSION= 1.0.1
-PORTREVISION= 14
+PORTVERSION= 1.1.2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= CRATESIO
DISTFILES= ${CARGO_DIST_SUBDIR}/${DISTNAME}${CARGO_CRATE_EXT}
MAINTAINER= nbari@tequila.io
COMMENT= Git tag semantic version bumper
+WWW= https://github.com/nbari/gbump
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -14,54 +15,70 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgit2.so:devel/libgit2 \
libssh2.so:security/libssh2
-USES= cargo ssl
+USES= cargo localbase ssl
-CARGO_CRATES= aho-corasick-0.7.6 \
- ansi_term-0.11.0 \
- atty-0.2.13 \
- autocfg-0.1.7 \
- bitflags-1.2.1 \
- cc-1.0.47 \
- cfg-if-0.1.10 \
- clap-2.33.0 \
- getrandom-0.1.13 \
- git2-0.10.1 \
- hermit-abi-0.1.3 \
- idna-0.2.0 \
- jobserver-0.1.17 \
- lazy_static-1.4.0 \
- libc-0.2.65 \
- libgit2-sys-0.9.1 \
- libssh2-sys-0.2.13 \
- libz-sys-1.0.25 \
- log-0.4.8 \
- matches-0.1.8 \
- maybe-uninit-2.0.0 \
- memchr-2.2.1 \
- num_cpus-1.11.1 \
- openssl-probe-0.1.2 \
- openssl-sys-0.9.52 \
- percent-encoding-2.1.0 \
- pkg-config-0.3.17 \
- regex-1.3.1 \
- regex-syntax-0.6.12 \
- smallvec-0.6.13 \
- strsim-0.8.0 \
- textwrap-0.11.0 \
- thread_local-0.3.6 \
- unicode-bidi-0.3.4 \
- unicode-normalization-0.1.9 \
- unicode-width-0.1.6 \
- url-2.1.0 \
- vcpkg-0.2.7 \
- vec_map-0.8.1 \
- wasi-0.7.0 \
- winapi-0.3.8 \
- winapi-i686-pc-windows-gnu-0.4.0 \
- winapi-x86_64-pc-windows-gnu-0.4.0
+CARGO_CRATES= aho-corasick-1.1.2 \
+ anstream-0.6.5 \
+ anstyle-1.0.4 \
+ anstyle-parse-0.2.3 \
+ anstyle-query-1.0.2 \
+ anstyle-wincon-3.0.2 \
+ bitflags-2.4.1 \
+ cc-1.0.83 \
+ cfg-if-1.0.0 \
+ clap-4.4.11 \
+ clap_builder-4.4.11 \
+ clap_lex-0.6.0 \
+ colorchoice-1.0.0 \
+ foreign-types-0.3.2 \
+ foreign-types-shared-0.1.1 \
+ form_urlencoded-1.2.1 \
+ git2-0.18.1 \
+ idna-0.5.0 \
+ jobserver-0.1.27 \
+ libc-0.2.151 \
+ libgit2-sys-0.16.1+1.7.1 \
+ libssh2-sys-0.3.0 \
+ libz-sys-1.1.12 \
+ log-0.4.20 \
+ memchr-2.6.4 \
+ once_cell-1.19.0 \
+ openssl-0.10.61 \
+ openssl-macros-0.1.1 \
+ openssl-probe-0.1.5 \
+ openssl-src-300.2.1+3.2.0 \
+ openssl-sys-0.9.97 \
+ percent-encoding-2.3.1 \
+ pkg-config-0.3.27 \
+ proc-macro2-1.0.70 \
+ quote-1.0.33 \
+ regex-1.10.2 \
+ regex-automata-0.4.3 \
+ regex-syntax-0.8.2 \
+ strsim-0.10.0 \
+ syn-2.0.41 \
+ tinyvec-1.6.0 \
+ tinyvec_macros-0.1.1 \
+ unicode-bidi-0.3.14 \
+ unicode-ident-1.0.12 \
+ unicode-normalization-0.1.22 \
+ url-2.5.0 \
+ utf8parse-0.2.1 \
+ vcpkg-0.2.15 \
+ windows-sys-0.52.0 \
+ windows-targets-0.52.0 \
+ windows_aarch64_gnullvm-0.52.0 \
+ windows_aarch64_msvc-0.52.0 \
+ windows_i686_gnu-0.52.0 \
+ windows_i686_msvc-0.52.0 \
+ windows_x86_64_gnu-0.52.0 \
+ windows_x86_64_gnullvm-0.52.0 \
+ windows_x86_64_msvc-0.52.0
PLIST_FILES= bin/gbump
+.include <bsd.port.options.mk>
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gbump