aboutsummaryrefslogtreecommitdiff
path: root/devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt')
-rw-r--r--devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt b/devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt
new file mode 100644
index 000000000000..281965e48c09
--- /dev/null
+++ b/devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt
@@ -0,0 +1,14 @@
+Install headers prefixed, as to not cause a possible conflict with
+different versions.
+
+--- textdocument/lib/CMakeLists.txt.orig 2016-08-10 16:06:47 UTC
++++ textdocument/lib/CMakeLists.txt
+@@ -44,7 +44,7 @@ install(TARGETS grantlee_gui EXPORT gran
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR} COMPONENT TextDocument
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR} COMPONENT TextDocument
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR} COMPONENT TextDocument
+- INCLUDES DESTINATION include
++ INCLUDES DESTINATION include/grantlee4
+ )
+
+ install(FILES