aboutsummaryrefslogtreecommitdiff
path: root/devel/hp48cc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hp48cc/Makefile')
-rw-r--r--devel/hp48cc/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/hp48cc/Makefile b/devel/hp48cc/Makefile
index 13d1c4078ebe..fffb1cf56756 100644
--- a/devel/hp48cc/Makefile
+++ b/devel/hp48cc/Makefile
@@ -21,13 +21,17 @@ MAN1= ${PORTNAME}.1
PLIST_FILES= bin/${PORTNAME}
PORTEXAMPLES= *
+OPTIONS_DEFINE= EXAMPLES
+
+.include <bsd.port.options.mk>
+
post-patch:
# Fix the Makefile to unbreak parallel builds
@${REINPLACE_CMD} -e 's,(YACC),& -o parser.c, ; \
s,(LEX),& -olexer.c, ; /mv/d' ${WRKSRC}/src/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif