aboutsummaryrefslogtreecommitdiff
path: root/devel/ice
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ice')
-rw-r--r--devel/ice/Makefile6
-rw-r--r--devel/ice/files/patch-cpp-include-IceUtil-IconvStringConverter.h15
2 files changed, 15 insertions, 6 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index f84d2197675b..d2e4a3e9e2b8 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -125,12 +125,6 @@ post-patch:
s|%%INSTALL_DATA%%|${INSTALL_DATA}|g; \
s|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/php/config/Make.rules.php
-.if empty(ICONV_LIB)
- # native iconv detected
- @${REINPLACE_CMD} \
- -e 's|<iconv.h>|</usr/include/iconv.h>|g;' \
- ${WRKSRC}/cpp/include/IceUtil/IconvStringConverter.h
-.endif
.if ${PORT_OPTIONS:MTESTS}
TEST_CMD= @cd ${BUILD_WRKSRC} && ${PYTHON_CMD} ./allTests.py
diff --git a/devel/ice/files/patch-cpp-include-IceUtil-IconvStringConverter.h b/devel/ice/files/patch-cpp-include-IceUtil-IconvStringConverter.h
new file mode 100644
index 000000000000..ba55870f7a0b
--- /dev/null
+++ b/devel/ice/files/patch-cpp-include-IceUtil-IconvStringConverter.h
@@ -0,0 +1,15 @@
+--- cpp/include/IceUtil/IconvStringConverter.h.orig 2013-10-04 15:48:14 UTC
++++ cpp/include/IceUtil/IconvStringConverter.h
+@@ -14,11 +14,11 @@
+ #include <IceUtil/UndefSysMacros.h>
+
+ #include <algorithm>
+ #include <iconv.h>
+ #include <langinfo.h>
+ #include <string.h> // For strerror
+
+-#if (defined(__APPLE__) && _LIBICONV_VERSION < 0x010B) || defined(__FreeBSD__)
++#if (defined(__APPLE__) && _LIBICONV_VERSION < 0x010B)
+ //
+ // See http://sourceware.org/bugzilla/show_bug.cgi?id=2962
+ //