aboutsummaryrefslogtreecommitdiff
path: root/devel/kf5-knotifications/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kf5-knotifications/Makefile')
-rw-r--r--devel/kf5-knotifications/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/devel/kf5-knotifications/Makefile b/devel/kf5-knotifications/Makefile
new file mode 100644
index 000000000000..a956c0def66b
--- /dev/null
+++ b/devel/kf5-knotifications/Makefile
@@ -0,0 +1,19 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= knotifications
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= devel kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 abstraction for system notifications
+
+LIB_DEPENDS= libdbusmenu-qt5.so:devel/libdbusmenu-qt5
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= codecs config coreaddons ecm windowsystem
+USE_QT5= buildtools_build core dbus gui linguisttools phonon4 \
+ qmake_build widgets x11extras
+USE_XORG= x11
+
+.include <bsd.port.mk>