aboutsummaryrefslogtreecommitdiff
path: root/devel/liberasurecode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/liberasurecode/Makefile')
-rw-r--r--devel/liberasurecode/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/devel/liberasurecode/Makefile b/devel/liberasurecode/Makefile
index 327599b5854e..8d791b60c563 100644
--- a/devel/liberasurecode/Makefile
+++ b/devel/liberasurecode/Makefile
@@ -1,18 +1,17 @@
# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
PORTNAME= liberasurecode
-PORTVERSION= 1.4.0
+PORTVERSION= 1.6.3
CATEGORIES= devel
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fuz@fuz.su
COMMENT= Unified Erasure Coding interface for common storage workloads
LICENSE= BSD2CLAUSE
+USES= gmake pkgconfig autoreconf libtool
USE_GITHUB= yes
GH_ACCOUNT= openstack
-
-USES= gmake pkgconfig autoreconf libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
@@ -20,4 +19,14 @@ CONFIGURE_ARGS= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
TEST_TARGET= test
+CFLAGS_amd64= -DINTEL_SSE2
+
+# documentation file names vary depending on architecture
+PORTDOCS= html
+
+OPTIONS_DEFINE= DOCS SIMD
+DOCS_CONFIGURE_ENABLE= doxygen
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+SIMD_CONFIGURE_ENABLE= mmi
+
.include <bsd.port.mk>