aboutsummaryrefslogtreecommitdiff
path: root/devel/libglade2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libglade2/Makefile')
-rw-r--r--devel/libglade2/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index c557d353e52f..e2513a4ca1dd 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -18,20 +18,16 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
USES= tar:bzip2
-.if !defined(REFERENCE_PORT)
-
RUN_DEPENDS= xmlcatmgr:textproc/xmlcatmgr
-USES+= gmake gnome libtool:keepla pathfix pkgconfig
-USE_GNOME= cairo gdkpixbuf2 libxml2 gtk20 referencehack
+USES+= gmake gnome libtool pathfix pkgconfig localbase
+USE_GNOME= cairo gdkpixbuf2 libxml2 gtk20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc \
--with-xml-catalog=${LOCALBASE}/share/xml/catalog.ports
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= XMLCATALOG="${LOCALBASE}/bin/xmlcatalog" \
CATALOG_PORTS_XML="${LOCALBASE}/share/xml/catalog.ports"
@@ -41,10 +37,9 @@ post-patch:
${WRKSRC}/configure
@${REINPLACE_CMD} -E 's/in (python.*)+ none/in none/' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s/ doc / /g" ${WRKSRC}/Makefile.in
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/libglade/2.0
.include <bsd.port.mk>
-
-.endif