aboutsummaryrefslogtreecommitdiff
path: root/devel/libpff/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libpff/Makefile')
-rw-r--r--devel/libpff/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/devel/libpff/Makefile b/devel/libpff/Makefile
index 2eea7acb91dd..83e80f73b9e9 100644
--- a/devel/libpff/Makefile
+++ b/devel/libpff/Makefile
@@ -1,15 +1,13 @@
-# Created by: Antoine Brodin <antoine@FreeBSD.org>
-
PORTNAME= libpff
-# If/When moving from experimental to alpha, switch to DISTVERSIONPREFIX to prevent PORTEPOCH
-DISTVERSION= experimental-20180714
-PORTREVISION= 1
+DISTVERSIONPREFIX= alpha-
+DISTVERSION= 20231205
CATEGORIES= devel
-MASTER_SITES= https://github.com/libyal/libpff/releases/download/${PORTVERSION:E}/ \
+MASTER_SITES= https://github.com/libyal/libpff/releases/download/${DISTVERSION}/ \
LOCAL/antoine
MAINTAINER= antoine@FreeBSD.org
COMMENT= Library and tools to access the PFF and the OFF formats
+WWW= https://github.com/libyal/libpff
LICENSE= LGPL3+
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -17,12 +15,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfwnt.so:devel/libfwnt
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS= --enable-python --with-libfwnt=${LOCALBASE}
CONFIGURE_ENV= PYTHON_CONFIG=${PYTHON_CMD}-config
-USES= libtool pathfix python:3.5+
+USES= cpe libtool pathfix python
+CPE_VENDOR= ${PORTNAME}_project
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
OPTIONS_DEFINE= NLS