aboutsummaryrefslogtreecommitdiff
path: root/devel/libphdi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libphdi/Makefile')
-rw-r--r--devel/libphdi/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/libphdi/Makefile b/devel/libphdi/Makefile
new file mode 100644
index 000000000000..0347af88b3e0
--- /dev/null
+++ b/devel/libphdi/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= libphdi
+# If/When moving from experimental to alpha, switch to DISTVERSIONPREFIX to prevent PORTEPOCH
+DISTVERSION= experimental-20221025
+CATEGORIES= devel
+MASTER_SITES= https://github.com/libyal/libphdi/releases/download/${PORTVERSION:E}/ \
+ LOCAL/antoine
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Library and tools to access the Parallels Hard Disk image format
+WWW= https://github.com/libyal/libphdi
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python
+CONFIGURE_ENV= PYTHON_CONFIG=${PYTHON_CMD}-config
+USES= fuse libtool pathfix pkgconfig python
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+
+OPTIONS_DEFINE= NLS
+
+NLS_USES= gettext
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_OFF= --disable-nls
+
+.include <bsd.port.mk>