aboutsummaryrefslogtreecommitdiff
path: root/devel/librevisa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/librevisa/Makefile')
-rw-r--r--devel/librevisa/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/librevisa/Makefile b/devel/librevisa/Makefile
new file mode 100644
index 000000000000..8e1a4a3ef292
--- /dev/null
+++ b/devel/librevisa/Makefile
@@ -0,0 +1,22 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= librevisa
+PORTVERSION= 0.0.20130412
+CATEGORIES= devel
+MASTER_SITES= http://www.librevisa.org/download/
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Library for interfacing test and measurement equipment
+
+USES= gmake pathfix libtool
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+# Workaround FreeBSD 9.1+ libusb not knowing LIBUSB_CLASS_APPLICATION
+CPPFLAGS+= -DLIBUSB_CLASS_APPLICATION=0xfe
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/libvisa.so
+
+.include <bsd.port.mk>