aboutsummaryrefslogtreecommitdiff
path: root/devel/libsigrok/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libsigrok/Makefile')
-rw-r--r--devel/libsigrok/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/devel/libsigrok/Makefile b/devel/libsigrok/Makefile
index 885ab9b8ca69..d635d2134e31 100644
--- a/devel/libsigrok/Makefile
+++ b/devel/libsigrok/Makefile
@@ -1,30 +1,34 @@
-# Created by: Uffe Jakobsen <uffe@uffe.org>
-
PORTNAME= libsigrok
PORTVERSION= 0.5.2
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= http://sigrok.org/download/source/libsigrok/
-MAINTAINER= bsam@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Framework for hardware logic analyzers, core library
+WWW= https://sigrok.org/
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= doxygen:devel/doxygen
-LIB_DEPENDS= libftdi1.so:devel/libftdi1 \
+LIB_DEPENDS= libcheck.so:devel/check \
+ libftdi1.so:devel/libftdi1 \
+ libhidapi.so:comms/hidapi \
libserialport.so:devel/libserialport \
libvisa.so:devel/librevisa \
libzip.so:archivers/libzip
-USES= compiler:c11 gnome pathfix libtool pkgconfig
+USES= compiler:c11 gnome libtool pathfix pkgconfig python:-3.9,build \
+ shared-mime-info
+USE_GNOME= glibmm
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
+
MAKE_JOBS_UNSAFE= yes
-USE_LDCONFIG= yes
-USE_GNOME= glibmm
-INSTALLS_ICONS= yes
+
+INSTALL_TARGET= install-strip
post-patch:
# libusb can be disabled via src.conf(5), so detect via pkg-config