aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/llvm-devel/Makefile')
-rw-r--r--devel/llvm-devel/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 93b1635b876a..45c3ae492dc8 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -157,7 +157,9 @@ LIT_DESC= Install lit and FileCheck test tools
LIT_VARS= _USES_PYTHON=python
LIT_PLIST_SUB= LIT_MOD_NAME=${LIT_MOD_NAME}
LLD_DESC= Install lld, the LLVM linker
-LLDB_BUILD_DEPENDS= swig:devel/swig
+LLDB_BUILD_DEPENDS= \
+ {PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR} \
+ swig:devel/swig
LLDB_DESC= Install lldb, the LLVM debugger
LLDB_IMPLIES= CLANG
LLDB_PLIST_SUB= PYTHON_ABIVER=${PYTHON_ABIVER}