aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm13/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/llvm13/Makefile')
-rw-r--r--devel/llvm13/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/llvm13/Makefile b/devel/llvm13/Makefile
index 67f500cd695f..642126d32fd8 100644
--- a/devel/llvm13/Makefile
+++ b/devel/llvm13/Makefile
@@ -297,7 +297,7 @@ MAN1SRCS+= clang.1 \
clang-tblgen.1 \
diagtool.1 \
scan-build.1
-CLANG_PATTERN= (c-index-test|clang|diagtool|hmaptool|scan-|Reporter.py|ScanView.py|scanview.css|sorttable.js|startfile.py|-analyzer|AnalyzerPlugin.so)
+CLANG_PATTERN= (c-index-test|clang|diagtool|hmaptool|intercept-|libear|libscanbuild|analyze-|scan-|Reporter.py|ScanView.py|scanview.css|sorttable.js|startfile.py|-analyzer|AnalyzerPlugin.so)
USES+= gnome
.endif
@@ -546,6 +546,9 @@ post-install-DOCS-on:
${RM} ${STAGEDIR}${LLVM_PREFIX}/share/man/man1/lit.1
${RM} ${STAGEDIR}${LLVM_PREFIX}/share/man/man1/FileCheck.1
.endif
+.if ! ${PORT_OPTIONS:MLLDB}
+ ${RM} ${STAGEDIR}${LLVM_PREFIX}/share/man/man1/lldb-tblgen.1
+.endif
.if ! ${PORT_OPTIONS:MMLIR}
${RM} ${STAGEDIR}${LLVM_PREFIX}/share/man/man1/mlir-tblgen.1
.endif