aboutsummaryrefslogtreecommitdiff
path: root/devel/love07
diff options
context:
space:
mode:
Diffstat (limited to 'devel/love07')
-rw-r--r--devel/love07/Makefile58
-rw-r--r--devel/love07/distinfo3
-rw-r--r--devel/love07/files/patch-Makefile41
-rw-r--r--devel/love07/pkg-descr7
4 files changed, 0 insertions, 109 deletions
diff --git a/devel/love07/Makefile b/devel/love07/Makefile
deleted file mode 100644
index 8c03eb30e3d2..000000000000
--- a/devel/love07/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# New ports collection makefile for: love
-# Date created: 01 Aug 2008
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= love
-DISTVERSION= 0.4-0
-CATEGORIES= games devel
-MASTER_SITES= SF
-
-MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Open-source 2D game engine
-
-LIB_DEPENDS= IL.1:${PORTSDIR}/graphics/devil \
- physfs-1.0.1:${PORTSDIR}/devel/physfs \
- freetype.9:${PORTSDIR}/print/freetype2
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_SDL= sdl mixer
-USE_GL= gl glu
-USE_LUA= 5.1+
-
-ALL_TARGET= default
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-PLIST_FILES= bin/love lib/liblove.a
-
-PORTDOCS= *
-PORTEXAMPLES= *
-
-post-extract:
- cd ${WRKSRC} && ${FIND} . -name "*.o" -delete
-
-post-patch:
- @${REINPLACE_CMD} -e 's|ILvoid|void|' ${WRKSRC}/src/opengl/Image.cpp \
- ${WRKSRC}/src/opengl/love_opengl.cpp
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/love ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/bin/liblove.a ${PREFIX}/lib
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/demos/*.love ${EXAMPLESDIR}
-.endif
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for f in changes.txt readme.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/devel/love07/distinfo b/devel/love07/distinfo
deleted file mode 100644
index 99a43ff681e0..000000000000
--- a/devel/love07/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (love-0.4-0.tar.bz2) = b77ed79c7d2aedc0e7c79c8631db0681
-SHA256 (love-0.4-0.tar.bz2) = 287f0f16ac419fd2339ed5c0eef9123745c3ef9424086a3365b3d2468969156d
-SIZE (love-0.4-0.tar.bz2) = 846487
diff --git a/devel/love07/files/patch-Makefile b/devel/love07/files/patch-Makefile
deleted file mode 100644
index f7243aaff534..000000000000
--- a/devel/love07/files/patch-Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
---- Makefile.orig 2008-08-29 03:42:40.000000000 +0400
-+++ Makefile 2008-08-29 18:09:43.000000000 +0400
-@@ -3,20 +3,19 @@
- # You may need to modify parts of this makefile for your system.
- ######################################################################
-
--CC = g++
--CFLAGS = -g0 -O3 -Wall
--CFLAGS_MOD = -g0 -O3
-+CFLAGS += -Wall
-+CFLAGS_MOD = $(CFLAGS)
- BINDIR = bin
-
- # Inclusion paths.
--INCLUDE_SDL = -I/usr/include/SDL
--INCLUDE_LUA = -I/usr/include/lua5.1
-+INCLUDE_SDL = `$(SDL_CONFIG) --cflags`
-+INCLUDE_LUA = -I$(LOCALBASE)/include/lua51
- INCLUDE_LIBLOVE = -Isrc/liblove/include
--INCLUDE_FREETYPE = -I/usr/include/freetype2
-+INCLUDE_FREETYPE = -I$(LOCALBASE)/include/freetype2
-
- # Linker flags.
--LD_LUA = -llua5.1
--LD_SDL = -lSDL
-+LD_LUA = -L$(LOCALBASE)/lib/lua51 -llua
-+LD_SDL = `$(SDL_CONFIG) --libs`
- LD_PHYSFS = -lphysfs
- LD_FREETYPE = -lfreetype
- LD_GL = -lGL -lGLU
-@@ -27,8 +26,8 @@
-
- default: prep $(BINDIR)/liblove.a love
-
--INCLUDE_COMMON = $(INCLUDE_LUA) $(INCLUDE_SDL) $(INCLUDE_LIBLOVE)
--LD_COMMON = $(LD_LUA) $(LD_SDL)
-+INCLUDE_COMMON = -I$(LOCALBASE)/include $(INCLUDE_LUA) $(INCLUDE_SDL) $(INCLUDE_LIBLOVE)
-+LD_COMMON = -L$(LOCALBASE)/lib $(LD_LUA) $(LD_SDL)
-
- #
- # liblove
diff --git a/devel/love07/pkg-descr b/devel/love07/pkg-descr
deleted file mode 100644
index f514f149392d..000000000000
--- a/devel/love07/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-LOVE is an open-source 2D game engine which uses the versatile Lua
-scripting language to create dynamic gaming experiences. It relies
-on OpenGL graphics and the SDL interface library to allow for
-cross-platform implementation and is an all-encompassing gaming
-environment for the development and enjoyment of 2D games.
-
-WWW: http://www.love2d.org/