aboutsummaryrefslogtreecommitdiff
path: root/devel/mate-common
diff options
context:
space:
mode:
Diffstat (limited to 'devel/mate-common')
-rw-r--r--devel/mate-common/Makefile21
-rw-r--r--devel/mate-common/distinfo2
-rw-r--r--devel/mate-common/files/patch-macros_mate-autogen35
-rw-r--r--devel/mate-common/pkg-descr4
-rw-r--r--devel/mate-common/pkg-plist10
5 files changed, 72 insertions, 0 deletions
diff --git a/devel/mate-common/Makefile b/devel/mate-common/Makefile
new file mode 100644
index 000000000000..6cd9aa17b97a
--- /dev/null
+++ b/devel/mate-common/Makefile
@@ -0,0 +1,21 @@
+#Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-common
+PORTVERSION= 1.6.2
+CATEGORIES= devel mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Common automake macros for MATE
+
+PORTSCOUT= limitw:1,even
+
+USES= gmake pkgconfig:both
+USE_XZ= yes
+USE_MATE= autogen
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/mate-common/distinfo b/devel/mate-common/distinfo
new file mode 100644
index 000000000000..be261317fc5b
--- /dev/null
+++ b/devel/mate-common/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/mate-common-1.6.2.tar.xz) = d7aafd79d98cdc22d4425baf49c39c16bc702d2c3d1065cc14d63718214a2059
+SIZE (mate/mate-common-1.6.2.tar.xz) = 66876
diff --git a/devel/mate-common/files/patch-macros_mate-autogen b/devel/mate-common/files/patch-macros_mate-autogen
new file mode 100644
index 000000000000..5f379b25633a
--- /dev/null
+++ b/devel/mate-common/files/patch-macros_mate-autogen
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/show_bug.cgi?id=427432
+https://bugzilla.gnome.org/show_bug.cgi?id=680363
+
+--- macros/mate-autogen.orig 2009-05-27 23:29:07.000000000 +0200
++++ macros/mate-autogen 2012-07-24 10:29:13.064750613 +0200
+@@ -77,6 +77,7 @@
+ vc_min_version=$4
+ vc_source=$5
+ vc_status=1
++ vc_option="--version"
+
+ vc_checkprog=`eval echo "\\$$vc_variable"`
+ if [ -n "$vc_checkprog" ]; then
+@@ -89,11 +90,19 @@
+ else
+ vc_comparator=">="
+ fi
++ # The most reliable way to check pkg-config version is to query the actual
++ # virtual
++ # pkg-config package entry's modversion. This works in all known
++ # implementations.
++
++ if test "x$vc_package" = "xpkg-config"; then
++ vc_option="--modversion pkg-config"
++ fi
+ printbold "checking for $vc_package $vc_comparator $vc_min_version..."
+ for vc_checkprog in $vc_checkprogs; do
+ echo $ECHO_N " testing $vc_checkprog... " $ECHO_C
+- if $vc_checkprog --version < /dev/null > /dev/null 2>&1; then
+- vc_actual_version=`$vc_checkprog --version | head -n 1 | \
++ if $vc_checkprog $vc_option < /dev/null > /dev/null 2>&1; then
++ vc_actual_version=`$vc_checkprog $vc_option | head -n 1 | \
+ sed 's/^.*[ ]\([0-9.]*[a-z]*\).*$/\1/'`
+ if compare_versions $vc_min_version $vc_actual_version; then
+ echo "found $vc_actual_version"
diff --git a/devel/mate-common/pkg-descr b/devel/mate-common/pkg-descr
new file mode 100644
index 000000000000..cc145d2aabc7
--- /dev/null
+++ b/devel/mate-common/pkg-descr
@@ -0,0 +1,4 @@
+This is a collection of automake macros used for developing new MATE
+applications.
+
+WWW: http://mate-desktop.org/
diff --git a/devel/mate-common/pkg-plist b/devel/mate-common/pkg-plist
new file mode 100644
index 000000000000..b6246e585cb1
--- /dev/null
+++ b/devel/mate-common/pkg-plist
@@ -0,0 +1,10 @@
+bin/mate-autogen
+bin/mate-doc-common
+man/man1/mate-autogen.1.gz
+man/man1/mate-doc-common.1.gz
+share/aclocal/mate-common.m4
+share/aclocal/mate-compiler-flags.m4
+%%DATADIR%%/data/omf.make
+%%DATADIR%%/data/xmldocs.make
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%