aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-seq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ocaml-seq/Makefile')
-rw-r--r--devel/ocaml-seq/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/ocaml-seq/Makefile b/devel/ocaml-seq/Makefile
new file mode 100644
index 000000000000..12ca80077edc
--- /dev/null
+++ b/devel/ocaml-seq/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= seq
+PORTVERSION= 0.2.2
+DISTVERSIONPREFIX= ${PKGNAMEPREFIX}${PORTNAME}-
+CATEGORIES= devel
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= freebsd@dev.thsi.be
+COMMENT= Compatibility library for the iterator type of OCaml
+WWW= https://github.com/c-cube/seq
+
+LICENSE= LGPL21
+
+USES= ocaml:dune
+USE_GITHUB= yes
+GH_ACCOUNT= c-cube
+GH_TAGNAME= 6934813195285661cba3e017e7d3cd79d362bb2f
+USE_OCAML= yes
+
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
+PORTDOCS= LICENSE README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/${PORTNAME}/seq.cmxs
+
+.include <bsd.port.mk>