aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Modified/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-File-Modified/Makefile')
-rw-r--r--devel/p5-File-Modified/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/p5-File-Modified/Makefile b/devel/p5-File-Modified/Makefile
index 2283ce7385ee..57a05de1fd23 100644
--- a/devel/p5-File-Modified/Makefile
+++ b/devel/p5-File-Modified/Makefile
@@ -14,8 +14,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for checking intelligently if files have changed
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -24,6 +23,10 @@ MAN3= File::Modified.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
post-patch:
${PERL} -pi -e 's/\r\n/\n/;' -e 's/^use warnings;//' ${WRKSRC}/Modified.pm