aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-PEAR_Info/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pear-PEAR_Info/Makefile')
-rw-r--r--devel/pear-PEAR_Info/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/devel/pear-PEAR_Info/Makefile b/devel/pear-PEAR_Info/Makefile
index 32b7f5b34ca2..95802c9f794a 100644
--- a/devel/pear-PEAR_Info/Makefile
+++ b/devel/pear-PEAR_Info/Makefile
@@ -10,15 +10,17 @@ COMMENT= Show Information about your PEAR install and its packages
LICENSE= PHP301
-BUILD_DEPENDS= ${PEARDIR}/Console/Getargs.php:devel/pear-Console_Getargs@${PHP_FLAVOR}
-RUN_DEPENDS= ${PEARDIR}/Console/Getargs.php:devel/pear-Console_Getargs@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}Console_Getargs>=1.3.3:devel/pear-Console_Getargs@${PHP_FLAVOR}
+
+USES= pear
+USE_PHP= pcre
+
+NO_ARCH= yes
OPTIONS_DEFINE= PHPUNIT
OPTIONS_DEFAULT=PHPUNIT
PHPUNIT_DESC= PEAR::PHPUnit support
-USES= pear
-
-PHPUNIT_RUN_DEPENDS= phpunit:devel/phpunit6@${PHP_FLAVOR}
+PHPUNIT_RUN_DEPENDS= phpunit6${PHP_PKGNAMESUFFIX}>=3.1.4:devel/phpunit6@${PHP_FLAVOR}
.include <bsd.port.mk>